Wyze Band stuck on "1748" screen

We have 2 Wyze bands. Mine is working great. My wife’s is not. Recently it stopped working but it’s doing something weird and I haven’t found any information on what to do.

It does turn on but it’s stuck on a screen with the green glowing band in a gray circle with “1748” in green letters below the icon. Swiping or pressing on this screen does nothing. The line is still at the bottom of the screen and when I hold down on it I get to a simplified settings menu with Band Info, QR Code, Reboot, and Power Off. I can click on any of these and get more information, see the QR code, reboot and power off and back on; but it just brings me back to the same icon with 1748.

I can’t connect to the band at all on the phone. I tried restarting the phone and bluetooth and it doesn’t fix the issue. My only other option is to let the band drain the battery and die and maybe that will reset things, But since it doesn’t work, it’s draining really slowly (now at 99% from full after 5 days).

Anyone have any other ideas? Any way to factory reset on the device since I can’t connect? Anything else I can do?

Thank you for the help.

Somehow the Band has rebooted and it appears that it is waiting to be added as a new band. 1748 sounds like the Band ID.
Try going into the app and deleting the Band. Then go to your device Bluetooth settings and if the Band shows up, tell the device to forget it.
Force close the App, restart and try adding the Band as a new device.
Post back and let us know if that worked.


I’m so stupid. Thank you so much!

Now I remember seeing that screen when I set it up the first day. No clue why it decided to factory reset on me but it’s back in the phone and working great.


Great! Glad that helped.