Wyze Band Not Showing Phone Call Notifications >> SOLVED

Notifications are working pretty well.

Tried to slide to ON the Phone and Text Buttons, but didn’t work.

Had to Manually grant permissions in the phone. (Android OS 10)

Go to Phone Settings>Apps and Notifications>Wyze (or Wyze Beta)

Check for permissions denied, then grant those permissions.

Now you can return to the BAND Device in the Wyze app and slide the phone and text buttons to ON

ALL OK Now

Chas

1 Like

I have a samsung s9 and I cant get texts or calls to work. I cant figure this out

@j_ingold Welcome to the community! There is some helpful information in this thread below and you can join the discussion here. :slightly_smiling_face:

I have the wyze app on an android phone. No phone or text notifications. Says I need google permission and i cannot figure that out. Thx

If you’re interested in using the Beta app it will correct the phone and text notifications problem.

I’m using Android and one thing that’s going to make a big difference is the app version. I am currently running Beta app 2.10.32 and it works great with the Band. Those that are using the production app will not have the same experience. They can either switch to the Beta app or sit tight until this app is fully released in the near future.

For non-beta app members, if you are interested in joining our Beta program, you need to follow these steps – learn more
https://wyze.com/become-a-beta-tester

This worked for CelticDragon :point_down:

2 Likes

I have the beta now, still not working for text and calls. Works for FB messenger though

Do you have these notifications turned on? See my post below.

1 Like

I dont want to shut off my app because I also have 3 wyze Cams in the app that I want to be able to use. Thx

You can keep your app open no need to shut it off. You only have to allow your app notifications on your phone so it can send notifications to your Wyze Band. Click on the pictures in the post above yours for details.

Every time I try to turn them on, I get the message that says I have to wait for google permissions to turn them on

What app version are you using? It doesn’t sound like you’re on the latest Beta app.

To find what version of the app you have, follow these steps.

  1. Open the Wyze app on your phone/tablet
  2. Go to the Account tab
  3. Tap on About
  4. Look for “vX.X.XX” under the Wyze Logo.

I updated to v2.10.32 now I can turn them on.

1 Like

Still no notifications for text

After you tap on notifications it should take you to the notifications settings. Like the pic below. You will have to allow text notifications.

4 Likes

Keep in mind that if you’re not using the default text messaging app, you might have to scroll to the bottom and select “other programs” and find your messaging app to enable notifications from it.

3 Likes

Hi, @robert8! You’re exactly right. I had to do that very thing by scrolling down the list of Apps and turning on all the ones I needed. :slightly_smiling_face:

1 Like

I have a question as well… I have done all of the above, moved to the beta version, all permissions granted, had to restart my phone. I now get call notifications. Texts are sparce. I get one from one person and don’t see one from someone else. All using the classic text app for Samsung.

Any ideas?

Hi, @EliteEmpress. Welcome to the community! If you have all the App notifications turned on, and you’re using Beta app version 2.10.32. it should be working correctly.

The only thing I can think of atm would be to turn off the BT on your phone then turn it back on. This may help to get better connection between the Wyze Band and your phone. If you continue to have problems, I recommend contacting Wyze support and start a support ticket.

3 Likes

Update: I am now receiving all texts and notifications as designated from the Wyze App. It could have been the firmware update today to the band, but it is now working.

Thanks for all the help!

2 Likes