Wyze Band Factory Reset Stuck?

So apparently there’s no way to delete uploaded photos for the Wyze Band clock face background.
Googleing it out, I find everyone running into brick walls, and no solid answer from Wyze Labs except “Reboot” and “Reset”. So I do the “Reboot”… Nothing doing… Next logical step, do the “Reset”, answer OK… Reset started a few hours ago… Is it stuck? Is there any way to restart this little thing?
Further research across the net is fruitless. Someone called “Brenda” has a nice picture on the support site, but no answer either, never mind a warning or consequence …
Email sent today 8/1/21 to Wyse Support… We’ll see how good the answer is whenever it does come back at me… stay tuned…
Jim

In the scheme of things that “Don’t work” Wyze support is leading the pack

2 support cases with no call back…4 weeks and counting.

Let’s give them a chance to answer within 72 hours, if no response, then an adverse Google and Amazon review would help others reconsider their purchasing decisions. The old adage “Give them plenty rope, they’ll hang themselves” applies.

Let’s give them a chance to answer within 72 hours, if no response, then an adverse Google and Amazon review would help others reconsider their purchasing decisions. The old adage “Give them plenty rope, they’ll hang themselves” applies.

Welcome to the Wyze community @jim-benitez!
I’m sorry you’re having this experience. Do you have a ticket number for this?
I would also suggest calling. It may be inconvenient for some users, but you’ll get a better response.

(206) 339-9646

WEEKDAY HOURS:
Monday - Friday 4 AM – 8 PM PT
WEEKEND HOURS
Saturday 8 AM – 4 PM PT

1 Like