Wyze Band - Connection Lost - Disconnected with Wyze app

Every morning when I try to invoke Alexa on the Wyze Band by pressing on the bottom of the band screen, I get an error “Connection Lost - Disconnected with Wyze app.” message. To resolve this, I open the Wyze App and then go into the Wyze Band and let it sync and then I can invoke Alexa. This has been happening every morning, and sometimes throughout the day, for about three weeks, but it didn’t happen before as consistently. Seems to be a new issue.

Details:

  • iOS 14.0
  • Wyze App: v2.13.22
  • Wyze Band Firmware: 1.0.7.96
    (however, this issue was occurring before the last update of each of these)

Any ideas on how to fix this annoyance?

If you haven’t already, I would suggest opening a ticket with CS.

But, there are lots of people here that may have insights that I am not able to offer. I do not have alexa.

Done - ticket number 42500.

There is s new feature in IOS 14 which could be causing your issue. It called Private Address and allows your device to randomly assign MAC addresses when connecting or reconnecting to your network. It’skind of hidden and defaults to on.
Causes problems on some WiFi and not others.
Go to Settings/Wifi. Click on this Info Icon by your selected network and turn the Private Address button off.
image image

1 Like

I’ll try that. Thanks.

Yeah, I don’t have Apple either. :upside_down_face:

1 Like

Unfortunately turning off the Private Address on my WiFi did not fix the issue. After trying it for 3 days I still get the Connection Lost at least once a day when trying to invoke Alexa, normally the first time I try to use it in the morning.

I had also noticed that I had turned off Background App Refresh for the app (Settings -> Wyze) to help try to fix an issue with the app using up the battery. That didn’t actually help with the battery and it must have been fixed with a subsequent release of the app, so I’ve turned that back on, but that hasn’t fixed the Connection Lost issue either.

I had also changed the location access for the app to “While Using the App” from “Always” (Settings -> Privacy -> Locations Services -> Wyze) to help with the battery issue, but I will now try with “Always” to see if it helps with the Connection Lost issue without affecting the battery.

No response yet from Wyze Support.

I’m having the same problem with the Wyze band, but mine started a few days ago when I upgraded my iPhone to iOS 14. I’ve tried rebooting phone, band, bluetooth, connecting band to charger to connect via bluetooth and the other options mentioned in this post.

Will I lose my data if I do a Reset on the band as I’ve got 3 days of information in the band that I would like to keep?

Other issues: Why does it take Wyze so long to reply to support tickets. This is unacceptable considering they are selling security devices and when my home or shop is having issue’s with the security devices, the lack of quick support is opening up a legal issue for them. Could you imagine if ADT security took 3 days to reply???

I was an early adopter of Wyze technologies and think the company is fantastic with the pricing of the new products they release, but they need to take time out of R&D and devote to their employees to technical support if they hope to keep up this speed of new product release.

1 Like

Wyze Support got back to me and suggested that I set the location service as “Always”, which I had already done yesterday. I also rebooted the device.

So far this has not worked as I had the same problem this morning. I’ll give it a couple of days of testing before responding.

I did realize that I don’t actually need to go into the Wyze Band within the Wyze App to (temporarily) fix the issue. I just need to open the Wyze App.

Thanks for sharing your experience. Good luck, and I hope you find a resolution.

Hi! I reported the same issue (iOS 14) and Wyze Support told me to change Location services to “Always” and to have it on ( :triumph: I particularly do not like that, but OK, had to check if this was the reason).

After trying this for 4 days, the connectivity problems persist :confounded:: band keeps disconnecting (4-5 times a day), having the cellphone with me all the time , Bluetooth always on, location services always on, and of course Wyze app in the background. Besides, I’ve performed a couple of factory resets and issues were still there. Bluetooth range is worse than in Mi Band 4 :-1:.

The problem is not the disconnection itself (unpleasant, though), but the fact that it does not reconnect automatically: I have to go to the app and manually sync to recover the connection.

Besides, I’ve noticed something strange: many times, the “no bluetooth” icon appears in the band, but I still receive notifications from my phone (meaning there still is a connection); nevertheless, I can’t use Alexa or other features.

Although I’ve been using the band for a month or less, I “have the feeling” that the connection issues appeared with the latest band firmware/Wyze app update.

Other issue: using the activity tracking mode, 1/3 of the times the band does not record my heart rate. This seems to be happening randomly, since one day I did a 2-hours routine and divided it into several tracking sessions with my Band, and it was in the second one (unfortunately the longest one) where my heart rate was not tracked. Of course, I did not change any configuration at all, just started and finished several “free training” tracking sessions in a row.

Hope it helps to see what’s going on. If there’s anything you can’t understand due to my (basic) English, please tell me!!

Changing the location services to “Always” has not helped. Rebooting the device has not helped. The first time in the morning when I try to invoke Alexa, I get the “Connection Lost - Disconnected with Wyze app.” error. It sometimes happens during the day, but most of the time it’s just that first time in the morning. When I open the Wyze App and go into the Wyze Band, then I can invoke Alexa without the error.

I’m on iOS 14.0.1 now.

I’ve replied to Wyze Support that their suggestion of changing the location services to “Always” has not helped. We’ll see what they say.

I’m on Android and have to deal with this a few times a day. It’s really frustrating.

Location services have to be ON. I have checked that this is the key (of course, for the Wyze app, location services have to be set to “Always”). In my case, the number of daily disconnections has decreased to just a couple. Every time it seems to be disconnected, I can´t use Alexa but I can still get the notifications from my phone.

However, I am strongly against having location services always ON: in addition to the privacy issues, we have the increased battery drain in the phone.

This is a very important limitation and I am seriously considering sending back the two bands we got.

Same here! One more frustrating thing to deal with.

I’ve given up on using Alexa with the Wyze Band, About half the time I get the “Connection Lost - Disconnected with Wyze app” message. When I don’t get this message, about half the time my request doesn’t work. Sometimes I get a request timeout. Many times when I think I’ve successfully set a timer, the timer never goes off. Many times I’ve checked the status of a set timer and it says I have no timers.

Time to move on.

1 Like

Hi @paulpaulbarber-net While I don’t have a soluton for the Wyze Band,
I do wish you Happy Birthday! :birthday: :confetti_ball: :saxophone:

2 Likes

I have the same problem, every morning my band is disconnected, I have to open the Wyze app to reconnect. Hopefully they fix this quick.