Wyze Band connection issues

Just got the new wyze Band was really stoked, however the bluetooth is constantly disconnecting from the phone / app really sucks. Emailed support no response, now I’m not so stoked looking to send it back. If anyone has a fix that will be great.

MODERATOR NOTE:

This topic has been moved to the #early-access forum category. Please keep all discussion of Early Access products here until the product(s) have been publicly released.

13 Likes

I too had an issue with the Bluetooth. I did a reset, started over, and it connected without issue. Still not sure what happened, but it hasn’t happened again.

TG

1 Like

I had to reboot my Android phone. Then it reconnected, went through updating software and now have no problem

I did a reset several times and still no luck.

4 Likes

Same issue here. iPhone and Wyze Band. Stays connected for 2-4 hours and then loses connection. I have to unpair bluetooth and repair. Then repeat the process 2-4 hours later.

7 Likes

I had the same problem this morning. Worked pretty much all day yesterday, but dropped BT this morning and do the repair “dance” on the iPhone.

1 Like

Got the band yesterday and will not stay connected to my iPhone. I reboot both, force close the app, etc. will not stay connected. I know this was on $25, but this is junk so far. Sent a message to support, will probably send back if they can’t resolve and the product keeps connected.

2 Likes

I have my phone set to not shut down the background app processes related to Wyze and, when I close the app the icon is still up top in the status/notification area so, it’s still running as a background process but, if I close the app, the watch loses connection. I did not really want to have to run the full Wyze app all the time since it brings battery use up considerably on my galaxy s7. I have set everything possible on my phone to not interfere with it … am I just going to have to keep the full Wyze app running all the time.? I am so used to tapping [Close All] to keep my phone power efficient and keep network communications minimal when I’m not doing something intentionally. Any advice?

5 Likes

If you have connection issue, do you use multiple devices with the same Wyze account ? It could possibly be that the band was connected to a different device that you use. Pls let us know.

1 Like

I was having this problem and found a link to a beta version of the app. Signed up for beta testing and from my experience it has fixed the problem. I staged some before and after testing and so far the new app is working correctly without having the app being active (neither active or in background) on my iPhone. That being the case I’m hoping to see the beta version released by WYZE…

However, I like a subsequent poster have had 3 issues so far with BT connectivity, and having to boot and/or reset the Band. Am going to track it for a couple of more days, and report if it persists.

TG

1 Like

Could you expand on your reply…I’m also seeing some connectivity (posted above, as well as in another post)…

I have the WYZE app both on my iPad as well as my iPhone, but have never connected the Band to the iPad. My app show a Band, 4 cameras, 2 bulbs, and 2 plugs. Again, the Band does show on the app on the iPad, but it’s never been connected. I actually turned BT off on the iPad, (it was on on iPhone), and stilll lost connectivity.

Thanks
TG

1 Like

if you use the same account on both ipad and iphone, then the band can connect to either.
The best way to check this is to turn off BT on iPad ( which sounds like you already did ). This will make sure that your iPhone is the only device that you band is connected to.

When you say you have connectivity issue, can you further clarify ? The way I typically check this is

  1. First open iphone, and open Wyze app. Tap into Wyze band, and see if the app is connecting to the band. If it does, then it is working normal. If it can not connect to band, then check if your iPad’s BT is on or off.
  2. If the iphone Wyze app can connect to the band, then there are 2 scenarios.
    2.1. if you leave the Wyze app open ( don’t wipe up to kill it ), then your alexa, shortcut should be working.
    2.2 if you wipe up to kill the app, then Alexa, shortcut will display “not connected to app”. But notification/call should continue to work.

Can you let me know which stage do you see connectivity issue ?

Followed your direction but still cannot connect.

  • BT on
  • BT connect to wyze band
  • Wyze app cannot connect to band, tap to try again

The BT on my iphone is saying connected however when I open the app it doesn’t sync/ connect. No Alexa, no types of notifications no find phone.

3 Likes

Recieved my Band 2 days ago & have been having connect problems since, I have not seen any of my Wyze devices in the Band so far. I have Rebooted 3 times, Did a RESET 2 or 3 times, finally deleted the Band & started over & still having connection issues, when i try to BT it says Wyze rejects. I get some notifications but not all. It is very disappointing as the only reason I bought the Band was to control my Wyze devices. I have 23 devices . Have 3 Camv2, ,3 Pan Cams, 7 Contact sensors, 3 Motion sensors, 2 Locks, 4 Bulbs & the Band. Actually i wa sent 2 Wyze Bands & neither have connected as advertised. I just clicked on a Shortcut to turn on a Bulb & it flickered & then nothing.

1 Like

As I said in the first post, I switched to the beta version to eliminate the need for active/background app requirement. I was having the same connectivity issues and thought that maybe that would help. As I stated in the another post, I did several before (pre beta install), and after (post beta install), and am convinced that it solved the lost of notification issue. I went over 6 hours without the app being available and was still receiving notifications.

The connectivity issue is that when I start up the app, I get message (24), that it cannot connect, (I think for syncing), and tells me to retry. If I look at BT on my phone the WYZEBand shows as connected…retried to connect as message says and I get the same thing again. So far the only working solution to get reconnected is to “reboot” the Band, “forget the device on iPhone BT, that’ll usually cause it to re-pair. I’ve also had to “reset” the Band and that worked as well but is more of a “pia”. Again, I had this issue with both versions of the app.

iPhone. When I lose connection the only solution has been to close the Wyze app. Unpair the bluetooth connection, Relaunch the Wyze App and select the Band, which will then ask to pair the device. After that, I’m good to go for between 2-4 hours before it happens again. The iPhone is the only device that is paired with the band. The Bluetooth connection shows as being connected, but the App won’t connect to the Band. It feels like it’s some sort of timeout issue. I assume that the phone is actually still connect to the Band but the App cannot connect for some reason. Anyway, that’s all I got. It’s very frustrating and sort of defeats the entire point of having a connected watch.

1 Like

Forgot to add to previous post, When i click on Wyze Band it tell me NOT CONNECTED, I click to connect & it says COULD NOT CONNECT TO BAND TAP TO TRY AGAIN ( 24-133 )

1 Like

thank you, which beta App version are you using ? that looks good ?

Just to confirm, you don’t use another device ( phone or tablet) that uses the same Wyze account ?