Wyze app draining my iPhone 7 battery?

Has anyone recently noticed a sudden issue of battery drain in their iPhone lately after using the Wyze app? I’ve noticed a SERIOUS battery drain issue in the past week or so and I’m tying it, potentially, to the app. That was one of the apps that I allowed to update in this time frame. For background: I have pretty much everything turned off on my phone – all the usual battery drain suspects are turned off because I either don’t use them, or don’t use them all the time (including Cellular Data, WiFi, and Bluetooth), so they’re off unless I actually need to use them. Since I updated the app, my iPhone battery has been draining a LOT faster than it has previously. Didn’t really think of the pattern until the phone unexpectedly drained completely on Monday from 49% to 0% in only about two hours – and the phone wasn’t being used for anything. Digging around in the options (making sure things were off that were supposed to be), I noticed yesterday that the Background Refresh for the Wyze app was on, despite the fact that I have it turned off for all apps on the phone. It should NOT have been on! I had to turn the option ON so I could then go to turn it off for the app, then turn it back off for the whole phone again. Thought that would take care of things, but, this morning, after having fully charged my phone overnight, and a short bit of time using the Wyze app (like, maybe two minutes tops) my battery went from 100% to 77%! The app was the only thing I used and it was only for those few minutes. The way it drains, it’s like something isn’t shutting down and continues to run, even though it doesn’t show in the phone that it is. So, just wondering if this is only happening to me, or if anyone else has noticed this. I’m wondering if maybe the most recent app update is corrupted, or bad, and might be causing this. There doesn’t seem to be any other reason for it, based in my investigation of the issue so far.

This may sound like a dumb question, but how old is the battery on your phone? With Li batteries, once they start loosing capacity, it’s a VERY steep curve. For example, with my previous &^%$# iPhone, it went from 2 - 3 hours of heavy use to 5 minutes in less than a week.

I have no idea. I bought it off eBay earlier this year. The battery health is at 87% and that’s actually UP from when I first got it (it was 84% then). This has only just started happening and seems to only be an issue after using the Wyze app. At least, that’s the pattern I’ve noticed so far.

Are you using location based rules on any app, including Wyze? This has been noted as a battery drain, and if you are doing it on the Wyze app needs to be noted here so they can be aware and correct it.

Nope. I don’t even allow Location Services to be on unless I’m using an app that requires it to work. When I’m done with the app, Locations Services is shut off. I found there was another Wyze app update last night and allowed the update to happen. After the update, I opened the app to check my events and cameras, and to see that the app was working, and my battery dropped 2%. It was at 34% when I opened the app. I checked events quickly and brought up the view from my outdoor cam, then closed the app and I was down to 32%. This whole process was maybe 2-3 minutes of time, at most. I haven’t yet opened the app today, because I had to fully charge my phone again overnight and I want to see how the battery acts today when I don’t use the app. It’s going to be hard not to check my cameras, but I’m going to see how the battery behaves before I try opening it.

Further update: Had to charge the phone up again last night (it wasn’t dead, but I knew I’d need it for quite some time today, and it needed to have a full charge). I have not opened the Wyze app all day today (so far. It’s 7pm right now and the phone has been on since 7:15am). I have used my phone for playing my usual games of Solitaire, using Cellular data for a few minutes at the grocery store for their app, and listening to music during my grocery shopping (just about 30 minutes) AND listening to music for another hour and a half at fairly loud volume while I mowed my yard. My battery is at 90%. This tells me that the app is at fault. It’s somehow still using battery when it’s not supposed to be. Does this need to be sent to Support?

FWIW… I have an iPhone 7 running Wyze app v2.25.21 under iOS 15.0.2. Battery is original and health is 88%. It’s been running off the charger for 2 days now and battery is at 84%. I started up the Wyze app, viewed a few Events and a live stream for a few minutes, put Wyze app in the background… will check battery level tomorrow.

1 Like

I haven’t had the app running in the background - I close out of all apps when I’m done with them. I also am on 14.3 OS. I have not been given the option to update the OS to 15.

Battery level is at 76% after 18 hours… less than 10% drain which is pretty good considering the hundreds of notifications received. Will kill the Wyze app and let it run another day…

If you’re running an iPhone 7, go to Settings > General > Software Update. I don’t think the OS update will help, but you should keep it up to date anyway. If updating doesn’t help, try deleting the Wyze app, reboot your phone and let it run for a day noting battery level difference. You won’t lose anything by deleting the app… just reinstall and log in to the app when you want and your Wyze settings will be retrieved and restored from the cloud.

I’ve done that for the OS. It’s not giving me an option to update. Just says I’m up to date.

I’ve toyed with deleting/reinstalling the app, but wanted to see if anyone else had the issue (and didn’t want to have to re-add everything back in)

I don’t know of any carrier that blocks iOS updates. You may want to give Apple CS a call.

You won’t have to re-add everything back from a Wyze app delete/reinstall.

Take a look at Settings > Battery > scroll down to the bottom and make sure something other than Wyze isn’t listed as the resource hog. Mine shows Wyze Notifications as 71% of battery usage activity. That is normal in my usage as I’m receiving hundreds to thousands per day. Maybe the difference between your iPhone 7 and mine is, as K6CCC sated, battery capacity/performance. The iOS battery health statistic isn’t the most accurate to rely on. I have another iPhone that reports battery health @ 91%, but it drains to nothing in 12 hours. :confused:

My main point of all this is that my phone’s battery has been working “normally” when I DON’T open the app all day. The battery drains “normally” as it had been for months prior to the last two Wyze app updates. Since that first update I allowed from the last two, my battery suddenly gone bonkers and drains rapidly when I open the app and check my cams. It’s not good.