Wyze App 2.24 Beta Test; Wyze Robot Vacuum Firmware Beta Test 8/18/2021

@WyzeHongfei @WyzeYichen

Weird issue this morning with the Vacuum. On Saturday I have it set to do normal cleaning. During this clean, it got hung up on the Coffee Table Leg, here is the image of what it got hung up on - it is a little piece of metal angled outward:

I then went to the Vacuum and freed it from the little piece of metal hanging down and clicked resume / continue in the app. The Vacuum did its normal spin to orient itself and then took off and started to clean the next room before completing the one it was in. Here is an image so you can see where it came from, red circle is where it got stuck and then you can see it went and started to clean the Family Room, leaving the Living Room incomplete.

I submitted a log of this: #288850
Vacuum Firmware: 1.6.173

I am trying out the spot cleaning feature (very happy to see it) and trying to understand why it sometimes tells me “There is no available area for spot cleaning.”, as seen in the first image.

Meanwhile, if I move the box - without resizing it - to touch a wall, it works. So I thought maybe the box needs to touch a wall to help the vac to locate the cleaning spot - but I am able to select a spot clean area in t



he middle of another room and it works fine.

Can anyone share what the criteria is for defining a spot clean area?

I have found and others have reported that you cannot mark an area which did not encapsulate and object.

For example, I tried to do a spot clean in an open area as you are and it was a no go as you see. But I circled my island and made it big enough to ensue there was space for the Vacuum and it was ok.

To see what I am saying, drag your box and drag it over an item - I marked your image with yellow areas. When you do that, you will see the message disappear. Wyze is aware of this, hopefully it will be fixed or enhanced.

1 Like

Thanks, I did notice that the message went away if I included a wall, for example.

Your reply also helps me realize that there is no harm in including objects in the spot clean area. For some reason, I was trying to avoid them.

Spot clean works fine for me.

Robot vaccuum mapping seems improved, but cleaning regressed.

  1. The bot has cleaned in loops around furniture for 15 minutes before moving on. Never experienced that with current firmware. 294273

  2. It has prematurely decided cleaning was finished, once even before perimeter cleaning ccompleted. Might have only happened when it got stuck during the clean. 294276 294281

Other than that the spot cleaning feature works well and the update was fine.

1 Like

I’ve been able to test and enjoy spot cleaning and the new algorithm. But I’ve yet to receive the skill email or the ability to use Alexa and assistant integrations. Has anyone else had this problem?

I have two vacuums. The first updated to the newest firmware without any issues… the 2nd never prompts to be updated. Both say “up to date” when I go to the Firmware Update screen even though one is on 1.6.173 and the other is on 1.6.126

Any ideas? I’ve tried jumping out and back into the beta program, reboots, etc. No dice.

1 Like

FW 1.6.173 was paused due to issues they had, looks like you managed to update one without issue before it was paused.

1 Like

still rip?

I’m on 1.6.173 with no issues except unfinished runs aborting a couple of times, but still no further Alexa integration other than start/stop whole area…no specific rooms. Spot cleaning works well. And multi levels! Has anyone else had any updates and or issues? Hope this is still in the works for a sooner rather than later update.
Happy Thanksgiving everyone!

I think the majority of us haven’t been able to try it because they pulled the firmware right away. I still haven’t been able to update past 1.6.126

I assume they are being extra careful with the next update. They don’t want to brick any more vacuums.

Those of us who upgraded successfully get to use a few of the new features early. Hopefully they have a new beta or non-beta release soon, but safety first.