Wyze Air Purifier Not Updating AQI and Graph in App

As of 12am, 1am, 7am, and 8am on my air purifier app, the AQI was 11 and all four dots were below the PM2.5 Health Guideline dashed line. So, is it the app or my air purifier?

1 Like

So today on the app the AQI is 5 and says it updated 35 minutes ago, but that’s not true as it’s been 5 all day. The graph has one dot at around 7am.

I’ve been dealing with two people at Wzye over this issue. One said they’d replace my air purifier a week ago, but I still have nothing. The other said they are looking at the software logs. I was even told that maybe the sensor was loose on the machine. Sounds like they just don’t know what they are doing!

Now Wyze decided to replace my Air Purifier. So it’s probably going to take 2 to 3 weeks before it arrives, which sucks but okay. And they are letting me keep the filter in my current purifier, so that’s good.

I received my air purifier on Saturday and I’m seeing the same behavior as @Resist.

For example, on Saturday when I started it up, the AQI was 4. It went down to 2 later that day and was reflected in the app, It’s been stuck at 2 ever since. However, on the machine, it’s now showing an AQI jumping around in the teens. After more than a day of the app not updating from AQI 2, I performed a factory reset and set the purifier up from scratch. It now shows an AQI of 16 in the app and I get a dot on the graph.

One thing I noticed is that after I factory reset the unit, but before I had removed the device from the app, I could still “control” the device in the app. For example, I would turn the air purifier off, and it was reported as off. Turn it back on and it reports as powered on. But the air purifier has been factory reset and so it isn’t actually responding to these commands.

It appears to be some communication failure between the device and the app. Like, server-side is reporting to the app without confirming with the device.

Before the factory reset, I did try resetting the Wi-Fi on the unit but that did not update the AQI. Nor did deleting the device and re-adding it after resetting the Wi-Fi, which I also tried. But a factory reset did update the AQI after setting the unit up again in the app.

As a follow-up, I lit a candle and blew it out near the unit. The smoke/soot caused AQI to shoot up into the 180s and the fan went into Turbo while in Auto for the first time since I’ve had the unit.

When I opened the app, it reported the AQI as 60 and would jump up and down with some frequency (checking it every few minutes), between triple digits and double digits. However, once the AQI got back down to 8, the AQI appeared to stop updating in the app. It seems that when the AQI is in single digits, the app stops updating.

So I believe this may be a software issue and not hardware.

No doubt it’s a software issue, just like every other software based product Wyze puts out…nothing but software issues! But I will see for sure when my replacement unit arrives (probably next month).

Tonight I move my air purifier into another room, so basically it was rebooted and not one single dot was on the graph in the app. Yet according to Wyze every time it’s rebooted there should be a dot on the graph. So now mine isn’t even doing that. I sure hope it’s hardware issue and the replacement works as advertised. Because right now I’m having flashbacks of my first Wzye Floodlight, luckily its replacement worked correctly. Why do so many of the products Wyze sells have issues? It’s very frustrating.

1 Like

Thank you so much for your testing! Any chance you could please submit a log and let me know when was that “smoke/soot caued AQI shoot up” so I could have the team to take a look at it. Thanks!

Thanks for the feedback! So the replacement device gives stable update on AQI now?

Hi Desmond,

I just performed the test again for good measure and sent a log:

580369

Unfortunately, I did not record a timestamp from when I performed the test the other day. I just did it on a whim, hence this second test, ready for logging.

(I just remembered that the first candle soot test would have been just before/around 17:00 on 2022/5/16 as I started to write the forum post and then left around 17:00 for an appointment with the post unfinished. So shortly before then would have been the time for the first test.)

The time for this second test would have been right before I sent the log. The acknowledgment e-mail from Wyze came in at 13:21 2022/5/17, so right around there, take a few minutes or so.

To put everything into context, the app does not consistently update the AQI when the air quality is “Good.” From earlier in the thread, it sounds like this may be normal. Anyhow, when I lit a candle and blew it out near the unit, this time the AQI shot up to 60 and the app reported it and continued to report the AQI level as it fluctuated between “Moderate” and “Good” until it settled into “Good,” at which point the number stalled at 36. I then sent the log after waiting for about four or five minutes to see if it would change. It did not. The AQI level is now around 4 on the unit but the app still says 36.

I, too, am not seeing Indoor AQI hourly dots on the graph. I rarely see the dots at all. When the AQI shot up, I did get a dot both times (just now and the other day) and then pretty much nothing, maybe one or two, after that. The graph is usually barren. Today I have two dots, one from the candle soot test.

Thank you! I will share the info with them team.

I have not received the replacement air purifier yet, Wyze hasn’t even shipped it to me! When I said the replacement worked I was talking about the Wzye Floodlight.

But it’s now been 5 days since Wyze said they were going to replace my air purifier and it hasn’t even shipped yet.