Worst Customer Support!

I have been having an issue with one of my black V2 cameras where whenever it is turned on it records a second of video where the scene is pink. I contacted Wzye customer support via chat and was told to reset the camera but was instructed to do it via the setup button. But all that does is run the setup process all over again and doesn’t reset the camera to factory specs, so it didn’t fix anything. What is even worse I wasn’t even told to delete the camera first from the app and she said to change the order of the camera to press the + button in the upper right corner of the app. There is no + button in the upper right corner, it’s a pencil icon and has been that way for awhile now. So I asked if I use a pin in the little hole in the back of the camera would that reset it and she said yes. I was like, this is what I should have been told to do first!!! But actually that hole is for the power light. So I just wasted about an hour of my time trying to fix this camera issue because I kept getting the wrong information from this so called support person. And the camera still records a pink flash every time it is turned on and if I turn off night vision mode then it doesn’t do this so clearly it’s an IR issue. I bought this camera in November of 2019, so I guess it’s just junk now.

This is what happens when a company starts making too many products, their customer support goes down the tubes.

1 Like

Save your self your time and forget there customer service and just buy a new one or change camera company.

2 Likes

Phone: (206) 339-9646
Toll free: (844) 999-3226
Monday - Friday 5 am - 6 pm PT
Saturday 8 am - 4 pm PT

Golly, definitely sounds like a training moment. Our apologies! Could you please give me your support ticket number from the chat?

1 Like

1140875

1 Like

So I ended up replacing the camera with a spare black V2 I had. But this camera is also doing the same thing. I have several other white V2 cameras in other rooms and they don’t have this issue.

This is so frustrating that every time the Black V2 camera is turned on it records a clip and it has a second of pink tint, so I assume that is what’s making it record. I don’t recall them doing this when I first got them. And why do they have to be so noisy when turned on?

Yes, they are the worst… I had problems with all 3 cams only the PTZ cams always wanting an upgrade when I would hit the upgrade button BAM!!! Cam would stop working and no way to fix it it basically bricked… Try to get a hold of CS was a joke… But they would all tell me the same procedure to correct the problem then send me a new one… NOW I DONT EVEN HIT THE UPGRADE BUTTON IN FEAR MY CAM ISNT GOING TO WORK… AND BESIDES THEY DONT RECORD ANYWAYS WITH A SD CARD… LET ALONE RECORD WHAT NEEDS TO BE RECORDED. ALWAYS TRYING TO CONNECT I FEEL I NEED TO JUST BUY CAMS FROM ANOTHER COMPANY

2 Likes

That is strange… I’ll report that part to the Product Team. I sent your ticket number over for quality control analysis. Thanks for giving me this information!

2 Likes

I agree support has been terrible. I have tried chat support two times now, and each time I get to number 2 or 1 in queue and suddenly it says click here to reconnect and I go back to queue position 8 or so. I think they have support agents gaming the system to do less work.

2 Likes

Also, the chat bot is pretty terrible. When creating a new ticket, it will ask me questions about products I didn’t select. That taxonomy is completely broken.

1 Like

Now I’ve noticed all my V2 cameras when turned on record a pink flash, even my Pan camera. And I received an email from Wyze saying they want to replace the black V2 camera I initially was having this issue with. Cleary it’s not a camera issue, it’s a firmware issue. Something happened with the last update. Now we just need Wyze to acknowledge there is an issue and fix it!

1 Like

It’s been 3 weeks and still no resolution to this problem. Wyze customer support has been a nightmare to work with! Since all of my V2 cameras and my Pan camera are having this problem it’s clearly a software issue, yet Wyze customer support keeps asking me to do these pre-made troubleshooting steps that I did before even contacting them. And then when all these didn’t work they want to see about a warranty replacement. I’m beyond frustrated with Wyze! Replacing my cameras won’t fix their software!!!

Samething happened to me… I got so fed up with the BS from them I dont upgrade when it pops up now. Because I know if I do its just gonna stop working…To tell me oh do this and that… It isn’t the camera it is the firmware update… Glad I am not the only one in the same boat…I will NEVER buy another Wyze cam again… Or I doesn’t catch what its supposed to… Even my local PD told me …And I bet your camer didn’t pick it up… I just laughed and said your right…

1 Like

@WyzeGwendolyn any feedback on the support experience? I could go on and on about poor experiences. I opened a ticket several days ago and have heard absolutely nothing. I tried the chat multiple times and magically got dropped when I was next in queue after waiting 45+ minutes to get to the top. We need a way to segregate support topics. For example, if I have a deterministic repro of an issue that looks like a software defect, we should have an avenue to work with and debug with your engineering teams. That avenue shouldn’t be the same as folks who are less tech savvy trying to do setup for the first time. I have feedback for several wyze products (I own them all), and I have no way to do that. You need a MVP program of sorts which will help improve your products and quickly bug bash before the broader community experiences the issues and floods your (overwhelmed) support system. Your support techs need to do more than copy/paste. You can’t scale tech support by hiring copy/paste techs. I am overall somewhat happy with my wyze setup, but there are leaps and bounds to go to get to true customer satisfaction.

3 Likes

Wyze customer support will only continue to get worse because they keep releasing new products and not fixing older product issues. This will be their downfall, unless whoever buys the company can bring things back under control. I can honestly say I won’t buy another Wyze product, even though some of them interest me. I just can’t see purchasing something that has ZERO customer support especially when their products have a history of having issues.

So please Wyze, hire real troubleshooters for customer support and not pre-written cut and past support staff!

I’ve reached the end of my rope with Wyze tech support. I’ve worked with them for months on my three V2 cameras. they’ve put me through every troubleshooting step they can think of, several different support staff, and several of them concluding they would simply replace the cameras, which are defective. they ask for pics of the the camera details which i’ve sent - several times, because they keep saying they hadn’t rec’d my email or the attachment.
the last email was a few days ago, when Philip in the Philippines said “due to Covid…” - his excuse for not replying or sending me the replacement cameras.

what to do? I’ve invested SO much time to learn their system and buy peripherals. I don’t really want to have to go to an entirely new system.

i first bought Wyze because they were literally in my backyard, just north of Seattle. I called them and actually spoke to one of their real partners. told them i was so proud of our hometown techies.

is there a Wyze person listening?

Sal in Seattle

1 Like

Hello @sltm1906 and welcome to the community.

Did they happen to give you a ticket number that I could have someone try and look into

Thank you for responding.
Here’s the most recent 4/14/21 Ticket #: 1181639 - Anthony, Regine, Philip. and many more.
To elaborate, the tech support seemed knowledgeable, articulate, respectful, etc. - no problem there.
They fell down when it came to following through and concluding the matter with the customer.
Each time I called back I got a different person and had to recount my entire history. It was exhausting.
Quality control?

Sal in Seattle

Did you ever get this resolved? This issue is starting to drive me up the wall.

Nope. Wyze still hasn’t fixed this issue.