Won't work with Google Nest Hub (Assistant)

I have been round and round with Wyze support and posted here and no one yet has come up with a reason that my Wyze products (all 7 of them) will not work with Google Assistant. It just occurred to me that since Google Home is so weirdly specific about which email you use to identify yourself (it randomly picked one from my list that I don’t even use any more, and no amount of talking to them or trying on my own, will allow me to change it to an actual active email of mine), that perhaps because I use my Outlook email address to log into Wyze, instead of the gmail one used by Google Home, it’s getting some kind of mismatch when trying to work with Google Home, and therefore Google Nest Hub.

So, to test this theory, I figured it would be as simple as just changing my email used with Wyze, but of course, that’s the ONLY thing you can’t change without going through customer service, and if it’s like Google Home, even that won’t get it changed so I’m screwed forever because no one told me the rules before setting up these accounts!

So, before I go to the trouble to try to change my Wyze email to the ridiculous one Google Home uses (and I’ll never get communications from either Wyze or Google Home again because it’s not an email I use any longer), can anyone tell me if this might be a possible solution to my incompatibility issue?

3 Likes

I don’t know if that will fix your issue, but with Wyze, one way to change your email is to delete all your devices, creat a new account with your preferred email, and re-add the Wyze products to that account. I know that’s a big huge pain in the butt to do, but if someone does verify that the email conflict is the problem, perhaps the same type of thing can be done instead to your google account to get a working email for that and leave the Wyze account as is.

When you say your Wyze Cameras do not work with Google Home can you elaborate? My son uses a different email address with Wyze than the one he uses for his Google Home and his devices work fine.

I use Alexa as I really dislike Google but my son is all Google. As I say his Google email address does not match his Wyze email address and he has no issues. He had to of course log into his Wyze account from Google Home setup to connect the two.

My Wyze devices will not work with the Google Nest Hub (assistant). In fact, when you open up the app and go to account settings and then “works with,” the only thing listed on my app is Alexa. I have uninstalled and reinstalled it now about 8 times, re-adding all my devises each time, and nothing works. I went to Wyze Support and they kicked it up as high in the food chain as they could and no one had a solution. All I freakin’ want to do is to be able to tell Google to turn off my lights! But it doesn’t recognize that I even have any Wyze devices, and yes, they’re all installed appropriately in Google Home, which I’ve also uninstalled and reinstalled at least 4 times. Apparently, my particular app, just simply doesn’t work with Google, but no one seems to be able to send me an update that will. This email mismatch was my final attempt, but if it’s not required, I’m not going through that test.

The integration for Google Home takes place on the Google side. The Wyze app does not currently support Google the same way it supports Alexa. So you won’t see anything in the Wyze app. But in the Google Assistant app you can add the devices there.

1 Like

I just get a black screen that says playing smart home camera and times out after a minute.

I love everything about wyze but connecting to my google hub is a deal breaker and also cant get a straight answer.

2 Likes

I have the same problem. How we can fix it. It supposes work.

I spoke to support and work around didn’t solve. Not sure if it’s with wyze or google. My friend had no issue with Alexa.

Its unfortunate because I love the cameras but everything else with my home is integrated with google so this is a deal breaker.

There’s so many threads with the exact same situation so I would think they would prioritize a patch.

Recently started to migrate to multiple Wyze cams from a single Nest Cam and this is a big issue for me. One of my main uses is as a baby monitor and i need the be able to view the Cam from my Home Hub.

Is there a reason why you moved from a Nest Cam to a Wyze one? I’m considering doing the opposite since watching my Wyze cams feeds on the Hub Max is waaaayyyyy too buggy.
I need it as a baby monitor and I have 10 weeks left to sort this out,

I recently discovered Wyze when I got some bulbs. I really liked the bulbs and I heard good things from coworkers about the Cams. I’ve been wanting to get more cameras but didn’t want them spread over multiple ecosystems, so I sold my Nest Cam on eBay and used the money to get the multiple cams. My only gripes so far are: the issue with integrating with my Home Hub, and the app crashing sometimes. But overall I have really been enjoying the Cam experience and I like the option for continuous local recording, without a subscription Nest only takes still frames when it detects motion.

Would be nice to discover how you have gotten it to perform. Myself and others have yet to gey Wyze to play nice with the Google Nest hub…

1 Like

Getting the same “Smart Home Camera” message on the Hub. Mine worked (somewhat) when displaying it on a Chromecast, but the functionality with the Hub is a must-have for me too.

It was working at some point?

For reference, I have signed into everything, my GHome and Wyze accounts use the same email address, and I’ve unlinked and relinked Wyze several times in GHome.

This appears to be a Google issue. My son is having the same problem with Wyze and Eufy cameras, however they work just fine on his Alexa Show.

No I have other brand cameras that work fine. This is a Wyze camera issue and not a Google issue. Google has at least addressed it and worked with clients not bury their head in the sand. Sad to think that Wyze seems eager to turn their back on the product that put them on the map

Gee, when we called Google about it they said it was an ongoing issue they were aware of and they were working to resolve it. At least they said that yesterday. Maybe today is different?

It definitely seems like a Wyze + Google issue. Wyze is working with other smart home devices (e.g. Amazon Echo) and Google is working with other cameras. It’s the connection of the two that’s the issue, which most likely has something to do with both.

From all the feedback, it sounds like Wyze pushed an update that either ignored or rolled back a usage of whatever Google API is needed for camera streaming, and they’ve neglected to put effort into getting it working again. From various posts here and on Reddit, it appears this has been the case for around a month.

They apparently are also working with Eufy as Eufy’s cameras are also having a tough time connecting to Google but seem to have no issues connecting to Alexa.

Good news however! Google is having no trouble connecting to Nest cameras at the moment! Although my neighbor says his Argos won’t connect to Google either.