Why robot vacuum is consuming so much battery in idle / stand by mode?

Hi Wyzers,

I don’t like to keep my robot vacuum charging all the time when its idle. So I have a smart plug which I will turn off when the battery is 80%+ charged. However, I have noticed that even in idle mode, when only thing the vacuum is doing is to remain connected to wifi, it consumes almost 10-13% battery every hour. Check attached images.

I am not sure why it should drain battery so fast in the stand by mode? It just doesn’t make any sense!

What are your experiences and opinions on this?

Regards,
PP

1 Like

I noticed the same thing. It’s difficult to get the device in sleep mode, and once it does, it took my vacuum around two hours for it to detect a low enough battery level to initiate a charging cycle and it has been on since.

I’m hoping that there is something that can be done to make sleep mode less energy consuming because this does not bode well for the overall battery life.

Well, I figured out a way. Its crazy, though! Remove the dust bin and leave the bot like that. You will be amazed to see how much less battery it consumes!

Yep, I left the Robot disconnected with its dust bin removed overnight and it lost only 3% of its charge. Sounds like they can apply some optimizations here and there :slight_smile:

Exactly. Just to keep checking if the dustbin is installed, its crazy amount of battery being consumed. Wyze team, please look into it. I dont think the fix should be that difficult!