Why is so hard o achieve "real time"?

it literally takes minutes to connect the camera to live stream, it is getting worse and worse!

it is AT LEAST ten times slower than yi camera or mijia which only takes 5-10 seconds to connect.

now if i want to find what is going on outside, it is much faster just go outside to check rather than open app to connect live view, so frustrated!

if i am connected to the same local internet, why the live stream has to route to cloud?

add a logic check, if the same internet, use rtsp rather via cloud.

i am planning o flash all my camera w/ rtsp so that i don’t need wyze app (which fails us!) to connect live when i am at home

1 Like

update:

it stucks at getting video…

it may hv sth to do with rtsp (i hv one camera flashed w/ rtsp)

earthsci is correct (thanks for quoting me here)

Just flash your camera back to the original firmware and I think you’ll see it works fine in the app again. All mine were running badly on the RTSP firmware. I flashed them all back to the main supported firmware and all are now fine.

Wyze’s RTSP firmware is crap and unsupported. It not only does RTSP badly, but really kills the original app performance as well.

1 Like

The 2.4 bands are more than crowded these days… just now starting to see it on 5Ghz

Many ISP provided boxes provide for a "Guest " network. If that’s an option, you can activate it on 2.4 , then put only your Wyze devices on it. Helps with the Wifi congestion but you are still limited by whatever your internet connection speed is.

This still doesn’t help if you have channel overlap among all of your neighbors and their devices.

1 Like

I am on Fios. My router supports 2.4 and 5. Pretty much any device I own utilizes 2.4 for connecting to the network via wifi. This includes Ring. I assume the reason the WCO Base uses a LAN connection is to connect to 5g?

That being said, from my cellphone I connect Live to my V2 in a second or so. My WCO takes about 3 seconds.

I have an old iPad. I have it Live streaming my V2.

From my general experience, the live stream, when active, is roughly 1 second behind on most devices.

People complain here about delays. I have a Ring Doorbell Camera. If someone knocks or rings, it can take 10 seconds or longer from when I click the alert until I am connected Live. Same delay if I just randomly click to see the live feed directly from the App.

i think rtsp partly (if not solely) to blame for the delay in my extra long conncting time

the step 1 and 2 are normal but stuck at step 3 getiing video data…

Very true. Just helps a little within your system. I don’t know what, other than moving, you can do about that issue as I understand it. Please post any solutions you might have!:hugs:

i think the prime reason is the bug of software.

whenver u turn on rtsp option, it will affect the speed of wyze cams (even though not using rtsp live stream yet)

1 Like