Why is my night vision blurry and with halos?

I have the Wyze Cam 2, and placed it in a housing outdoors (not behind a window), but am getting strange video from it at night when the IR lights are turned on. Any thoughts on what is happening and how to fix it? Here is what I am seeing:

I have cleaned the lens, so I don’t think it’s that - front and center (the main light ring in the center) is actually pointed at a tree, so not super reflective there…

I am running the RTSP firmware, if that matters.

Thank you very much for any help - I appreciate it!

Here is with a light on: (glare from that light is expected, I just mainly wanted to show that the lens seems to work OK except w/ the IR only on…)

When you say “in a housing”… Is there anything in front of the lens? Because anything will reflect, refract, or diffuse the LEDs.

@rrands One of my black v2 cams did the same thing a while back. I had to take the cam apart and clean the small round glass, problem solved. I’m guessing your v2 is having the same problem.

See this thread and long discussion on foggy images.

1 Like

not really - here is a link to the housing it is in, but it’s basically clear around the front…

1 Like

I guess I will have to go swap one out that is working OK (different area) & see if that does it or not - thanks for the info - these are new, so if bad I will send back -vs- opening, but a good option to check! :slight_smile:

1 Like

The very first “Customer Question” at that Amazon page reads as follows.

Q:For the white case, is there much reflective glare at night (in the 4 corners)?

Answer this question

A: It comes with a clear lense cover, but don’t use it - it reflects the night vision lights.

I see that now, but the housing doesn’t actually come with a clear lens or cover - the front square that holds it in place is totally open, so I don’t think that is causing the glare. I have one of these on the opposite side of the house that is not having this issue, so I will swap them today & check it out tonight.

Thanks for the help so far and for looking at that!

1 Like

Suppliers change products in the same listing so the reviews don’t mean much.

I’ve got a similar case for 2 of my V2 cams.
Paint the underside of the peak over the camera and on the sides. Light is reflecting off of the white plastic. I used black rubber instead of paint just because I had it. You could probably use a Sharpie.

1 Like

Or, you know, not use a housing. The V2s have proven hardy.

The only reason I do is for the mount. Easier to attach to a building. It does make it a pain to get to the SD card though.

1 Like

Maybe the IR lights are reflecting off of something on the inside of the camera?

Thought I would circle back - I did a couple of things, but seems I have a camera issue:

  1. Painted inside of housing black as per suggestion (didn’t make a difference for me, but I had it down & it was quick… :slight_smile:
  2. Swapped with another camera - issue followed this camera & I didn’t experience the issue in that location with the new camera, so I know the issue is with the camera somewhere.

Hope this helps someone else! :slight_smile:

2 Likes

Did both locations have the same white case? It’s possible the cases is still creating issues at the 2nd location.

I think @angus.black got it right when he suggested painting the exterior fins of the case black. You can test this very quickly by covering any part of the case that extends out with black electrical tape (or a Sharpie, as he suggested). Anything white in front of the camera will reflect the IR back at the lens and fog the picture. (You said you painted the “inside of the housing”, did you mean the inside of the exterior fins?)

Of course you could also have a bad camera, but if they are both in those cases with white fins that extend forward, I’d try darkening them first.

the mounts were identical, and at similar locations, just on different sides of the house - it’s definitely the camera…

for the enclosure, there really isn’t much “protruding” beyond the front to interfere with the IR, but I did go ahead as I mentioned and paint one of them matte black - no difference for me there - ymmv.

It does sound like warranty time.
Thanks for following up.