What happened to the rules?

Two questions:

Are you on the new Rules engine?

Is your Rule a Shortcut or a Schedule? I.e., do you have Start Time and End Time set in the Rule?

Have you tried delaying the turning on by about 1 minute?

I also posted earlier and asked, if you had different groups for which you could turn off selected bulbs except the ones you would like. It could be basically a timing issue and therefore, delaying the turning on of the 4 bulbs you want may do the trick. Or simply turn off the ones you would like off and leave the ones you want on, on.

I study the history and see rule actions don’t necessarily run in the specified sequence even though Wyze allows you to sort the actions