Web View vs. Live View

I’m confused!!! Can someone please enlighten me how is this possible?

I have Live View running on my iPad and Web View on my Mac simultaneously. The Web View has a 2 second latency, I guess due to traveling over the internet. The Live View has 4 second latency. Shouldn’t these be reversed as from what I understand the Live View is a direct connection between my iPad and the camera over local network.

What am I missing?!

The live view (Wyze app) should be the fastest when connected to the same network as the cam (local). There have been some reports of higher latency via live view recently, so that could be the causes

From what I understand, Live view is not a direct stream from the cam to your device. For it to show in the app, video still has to be sent to the cloud and verified on your account credentials before it can be sent to the app with those credentials on your device.

This may explain why the web view is faster. All that is happening server side and not returning to the app to be rendered.

I could be wrong, but I think it will try to go locally (still has to authenticate with a server first) if it can, but if not it will stream through the server.

I will have to test and research too. I could me mistaken as well. Will have to initiate a live stream and drop the ISP with the WiFi active and see if it drops the feed.

1 Like

@Mavens, ya’ll have been doing this a lot longer than me. Any definitive insights here?

2 Likes

It could have something to do with the protocol difference.

Last time I ran tests, between phone and Google and Alexa I got multiple differences even though all 3 of them were streaming locally, and sometimes there were differences on the same device between different attempts. Sometimes the latency would be x number of seconds delayed and sometimes it would be double or triple that on another time I tried even though it was the same device and still local.

If have to run similar tests again, and do so multiple times before I could conclude something similar to the above being a consistent outcome instead of a reasonable standard deviation… But honestly, 2-4 seconds is well withing reasonable tolerances either way. During my previous testing attempts some months ago when I was helping to test the new WebRTC protocol, I routinely found variances much greater than 2-4 seconds between testing cycles. I would not be surprised if they switch places sometimes to where the WebView has a greater latency than the app and sometimes switch again.

If you find that after many attempts over different days and different time of day that the variance is consistent, then I’d guess it has something to do with the protocol and coding differences in some way.

Regardless, Wyze’s VP recently implied to us that they’re looking into some kind of local streaming update in the near future, so we may see some changes coming up

2 Likes

I new that there are smarter people than me on this forum :slight_smile:

Thank you all

1 Like

I hope that they don’t brake anything else :wink:

1 Like