WAP configured Raspberry Pi/USB tethered Android phone -- Wyze Home Base Station

I am interested in having my Wyze cameras running at a vacant property that does not have internet access. I want to access the cameras with my phone/tablet Wyze app while I am not there. Since I do not have wifi/internet access at the property I considered using my Pixel 2 Wifi hotspot. Basically have the Wyze Base Station connect to the hotspot. After several attempts I have never been successful connecting the Wyze Base Station to the phone hotspot. I have questioned Wyze support and was told that it is not possible.

I decided to configure an RPi as an Access Point to behave as a traditional Wifi router and connect the phone to it as the internet source.

I have searched this forum for anyone using an RPi WAP with USB tethered Phone. I have not found anyone documenting this solution.

I am connecting the phone’s USB to the OTG USB port of the RPi.

Think RPi = traditional wifi home router, phone = cable modem.

So there are 2 things that need enabling/configuring.

  1. The USB tethering feature of the phone
  2. The Raspberry Pi

Raspberry Pi setup
I followed these instructions.
https://www.raspberrypi.com/documentation/computers/configuration.html#setting-up-a-routed-wireless-access-point

I had replaced one of the steps in these instructions.

Replace this step

sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

with

sudo iptables -t nat -A POSTROUTING -o usb0 -j MASQUERADE

USB Tethering setup
There are various ways to enable USB tethering on an android phone. This due to the various software versions. This video works with my phone.
https://support.bell.ca/mobility/smartphones_and_mobile_internet/google-smartphone.how_to_share_my_internet_connection_with_a_computer

If you are having issues with the USB tether acting flaky try these instructions to maybe correct the behavior.
https://support.google.com/androidauto/thread/13188342/usb-tethering-solved?hl=en

After both are configured plug them together.

Get a command promt to the RPi via SSH and key in ifconfig. usb0 should have an IP assigned to it. Below is the output of my command. This indicates that you set things up successfully.

pi@raspberrypi:~ $ ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 3562  bytes 240755 (235.1 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3562  bytes 240755 (235.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.63.160  netmask 255.255.255.0  broadcast 192.168.63.255
        inet6 fe80::acfb:1896:125d:52ed  prefixlen 64  scopeid 0x20<link>
        ether 06:fe:72:e5:2e:17  txqueuelen 1000  (Ethernet)
        RX packets 81  bytes 5893 (5.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 99  bytes 13744 (13.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.4.1  netmask 255.255.255.0  broadcast 192.168.4.255
        inet6 fe80::dad6:760:685d:988d  prefixlen 64  scopeid 0x20<link>
        ether e4:5f:01:5d:3d:21  txqueuelen 1000  (Ethernet)
        RX packets 68345  bytes 36455819 (34.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 34371  bytes 7113560 (6.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

pi@raspberrypi:~ $

This is what I am working with

1 x Raspberry Pi Zero 2 W

1 x Pixel 2 Android phone

2 x Micro USB cables plugged into Raspberry Pi.

  • One is used as the power source
  • One is connecting to the phone thru the female adaptor.

1 x female to female usb adaptor.

1 x phone usb cable.

  • One end plugs into the phone the other plugs into the female adaptor. This is the cable that came with the phone.

1 x Wyze Base Station FW ver. 4.1.62.37
2 x Wyze Cam Outdoor FW ver. 4.17.2.40
1 x Wyze Cam v3 FW ver. 4.36.3.19

Whoever told you that you can’t use a smartphone operating as a hotspot to connect your cameras is wrong. I do it all the time. The only limitation is that phone hotspot needs to operate on 2.4 GHz, and as is always the case, there are some character limitations that apply to any access point when using Wyze cameras. For example, when I originally set up my #$%^&* iPhone as a hotspot, the phone name and therefore the SSID was “Jim’s iPhone”. The Wyze cameras won’t accept the apostrophe in the SSID.

2 Likes

Here is the email chain. I removed my name and email specifics from the emails. I was not successful with the hotspot.

##- Please type your reply above this line -##
Your ticket (1585330) has been updated. To add additional comments, please reply to this email.
-------------------------------------------------------------

Keziah (Wyze) 
Nov 18, 2021, 10:26 PM PST 
Thanks for sending the link to the forum. 

As the post says, it is possible to connect the other Wyze Cameras like the Wyze Cam v2 to a mobile hotspot but not the Base Station. The Wyze Base Station requires a wired connection to a router for set up and use, unlike the other cameras that we have. However, once set up, you do have an option to change the connection from Ethernet to WiFi. You can find the information here: Wyze Base Station Setup Guide.

I hope this helps. Let me know if you have additional questions. 

Best,
Keziah | Wyze Wizard
Visit our Help Center: click here
Website | Facebook | Twitter | Instagram | YouTube

-------------------------------------------------------------

 
cretan-ibex
Nov 17, 2021, 6:31 AM PST 
This guys has it working. Has the firmware changed?
https://forums.wyzecam.com/t/connection-hotspot-problems/93114/5?u=cretan-ibex
 
 
Regards,
cretan-ibex
-------------------------------------------------------------
 
Keziah (Wyze) 
Nov 17, 2021, 12:38 AM PST 
Thank you for patiently waiting, 

This is Keziah, one of the specialists here on Wyze. I am sending this email to you regarding your concern about the Base Station setup via WiFi. Let me further help you with this. 

Unlike other Wyze devices, the Wyze Base Station requires a wired connection to a router for set up and use. You can also use a range extender with a built-in Ethernet port as long as it is paired with an existing router on the same network. 

Note: You will not be able to set up and use the Wyze Base Station with a mobile hotspot.

This is the reason why you were unable to pair the Base Station to your mobile hotspot. We still do not support this kind of setup. But we do have a Wishlist section of our forums where you can submit feature requests like this directly to our product team.

Here's a link to the Wishlist: https://forums.wyzecam.com/c/wishlist

We hope that helps! You can find more information in our Help Center article here. Should you have any other concerns, do not hesitate to let us know. Thank you for being part of Wyze! Enjoy the rest of your day!

Best,
Keziah | Wyze Wizard
Visit our Help Center: click here
Website | Facebook | Twitter | Instagram | YouTube

-------------------------------------------------------------

 
Rhexie (Wyze) 
Nov 11, 2021, 6:34 PM PST 
Hi,

Thank you for reaching out to the Wyze Wizards team. My name is Rhexie, and I’m happy to help.

I'm sorry to know that you're having issues connecting your Base Station. Here are some troubleshooting steps I would like you to try: 
•	To connect your Base Station to WiFi, follow the steps listed here. 
•	Make sure your Base Station is plugged into power and powered ON.
•	Make sure your Base Station firmware is up to date.
•	The firmware version will be listed on the Device Info page. Navigate to the Base Station page > Tap the settings icon > Tap Device Info. 
•	You can find the updates and firmware versions here. 
•	If the firmware is not completely up to date, go ahead and update it, and then try to connect wirelessly again. 
•	Reboot your router by unplugging it for 10 seconds, then plugging it back in and waiting for the WiFi to be available again.

If these steps do not resolve your issue, please reply to this email so I can continue assisting you.

Thank you for being part of Wyze. Feel free to contact us, should you have more questions. Have a great day!
Rhexie | Wyze Wizard
Visit our Help Center: click here
Website | Facebook | Twitter | Instagram | YouTube

-------------------------------------------------------------

 
cretan-ibex
Nov 11, 2021, 6:28 PM PST 
I am unable to pair the base station via wifi to my mobile hotspot. I continuously get an error after keying in the hotspot password.
-------------------------------------------------------------
This email is a service from Wyze. 
[MMMM05-4ED9] 

I did not catch that you were talking about the Outdoor cam. As that E-Mail says, you need a wired connection to the base station for initial setup, but once it is set up and configured to use an SSID, it could not care less if that SSID is a mobile hotspot or a home WiFi.