"Virtual Wall" as cliff sensor switch?

Every botvac that I have ever owned or researched has suffered from an inability to distinguish between the edge of a stair and a black bar printed on a carpet. After all this time I really had hoped that the botvac industry would have solved the false-cliff sensor problems. Until they do I’d like to offer a suggestion.

Don’t get me wrong this is not a complaint post. I love this vac. It functions far better than my last one.

Apparently, like most / all (?) botvacs my Wyze Vac does great until it hits the black lines in the printed, short pile, carpet that covers my entire kitchen and entry way. At that point it goes berserk… even bucking up and down in a failed attempt to back up or rotate in place… completely unable to figure out how to escape the rug and it’s many imaginary cliffs!

My house has no stairs so the cliff sensors are not critical. Rather than request that a hardware “sensor off” switch be added why not just expand the existing “Virtual Wall” function to solve this problem?

Just drag a large box “wall” around the problem carpet followed by a pop-up requesting the choice of the box being assigned the task of functioning either as a regular “no go wall” or as a “ignore cliff senser” region?

Yes, I could certainly use the “virtual wall” to keep the vac out of the kitchen completely (which I have tried) but that defeats the purpose of a vac… kitchens can get messy.

This should be an easy “logic” switch in firmware… since I rather doubt that the existing system includes an option for the addition of a cliff sensor “hardware” switch.

How have others solved this problem?


A software setting would be fine but…


Our vacuum had its first ever tumble down the stairs this week. It’s been avoiding them like a champ for a year.


That looks very MacGyver’ish. Good idea! :laughing:

Thanks for your suggestion. Black tape does indeed act as a “hardware” equivalent of the Wyze-Vac “Virtual” wall.

Unfortunately my post was not about ways to help CREATE boundaries. I’m seeking ways to prevent the DETECTION of boundaries… in this case the imaginary black edges my vac is “seeing” in my carpet.

1 Like

I hear you and you have a good idea. This is a user community forum. To make a suggestion and update the firmware you’ll need to open a Support Ticket with Wyze for them to address it.
You can also write this up or add to the #wishlist

p.s. Be sure to vote for this update in the #wishlist !

1 Like

No, I just meant to put a small piece of black tape over the sensor on your vacuum in your single floor use case, in order to have it ignore your carpet pattern.


I see! Posted a link to your idea/comment on the #wishlist. Thank you Customer! :slightly_smiling_face:

1 Like

Got it! I realized where you were going with that tape roll suggestion as I continued to read other posts! Thanks, I’ll give it a try.
Question? Why wouldn’t the sensor beam see the black tape as similar to a black stair edge… everywhere… causing it to “freeze up in fear”?


I thought the same and I don’t know. I’ve never tried it. If necessary perhaps one could place a small LED light or even a prism / mirror to trick it into always seeing the expected reflection at the sensor…

Maybe duct tape then, It shouldn’t be scared of the silver color?

1 Like

Pretty sure it’s a matter of seeing the light reflected? The color of the tape probably wouldn’t matter… Still gets blocked. Maybe someone will try and report back.

(Or maybe you were kidding)

Update: 01/22/21
OK… I spent more time than I care to admit carefully trimming Scotch green plaid frosted tape and then even more time carefully tucking those many tape layers down into the 4 clear plastic Cliff Sensors of my BotVac. Every new layer was then tested on my fake Persian rug (see photo below). The bot failed to escape the center “star” every single time… even up to 5 layers thick !

Finally, in frustration with my total lack of progress, I simply slapped on a layer AT AN ANGLE that covered the whole sensor guard. (see photo… the carefully trimmed layers are in top sensor… the final, slapped on, layer is at bottom of photo)

Result… the Cliff Sensor was, finally, completely disabled and the Bot easily escaped the rug ! !

Note - after all the time and effort it took to trim and carefully tuck all those 4 or 5 tape layers x 4 sensors down into the clear sensor pockets I was not about to rip them all out again to test if the solution was simply enough LAYERS or was it the ANGLE of the tape. If you test this remaining question please add your findings to this thread. Thanks.

Original Post: 01/09/21
Well, that was an interesting experiment. I covered the 4 cliff sensors with yellow plastic electrical tape. My logic was that if the sensor failed to receive ANY reflected light… or the expected color/wavelength… (like if black tape was used) it would conclude that it was hanging over a stair edge and stop… just as it does now when it “sees” the black patches in my Persian rug (see photo).

Apparently yellow tape ALSO fails to reflect the correct color/wavelength of light and it triggered a “Put Me Down!” reaction where the bot thinks that when all 4 sensors fail to detect anything it means that its wheels are all up in the air. It specifically asks that its wheels be put back down on the floor… even when both wheels are already clearly “grounded” !

One or two sensors reading “dark” must tell it to stop due to a stair edge… three or four dark sensors mean it must be upside down or up in the air.

Conclusion: the cliff sensors apparently have at least two functions that will be blocked with tape… resulting in a progress stop and “easy fix” fail. So… I’m back to suggesting the two option “Virtual Wall” solution proposed in my earlier post.

Rug Photo: bot fails completely to escape from the center of the star (tan region surrounded by black).


Hmm. Carver just posted a video of some guys flying a cheap robot vac. Toward the beginning they do the tape trick and it works fine, causing the vacuum to tumble down the stairs it avoided before.


@Customer I am so incredibly glad you linked to me to this thread! @MTBioGuy I am SO glad you mentioned this problem! In the beginning of the thread Customer referenced above, I was testing out ways to try to get my vacuum to use ramps, and I did tests that got it to work, then suddenly I started having problems and just couldn’t figure out why!

I had no idea that black tape causes cliff sensor problems, and I had ran some black Gaffer’s tape along the top and bottom of my ramp to hold it in place after the tests! No wonder it was suddenly spazzing out and acting weird. You guys saved me who knows how much time trying to figure out what’s wrong (at least I hope that’s the main problem! I’ll have to experiment a little now).

THANK YOU for leading me here and for posting about this issue. I will fix that on my ramp, and then instead of having to run boards along areas I don’t want my vacuum to go, I can just run some electrical tape (like underneath my bed). Virtual walls aren’t a good fix because I have to keep moving the vacuum between the basement and main floor, and then the map disappears each time, so virtual walls won’t work, and putting up boards all the time is annoying. This is AWESOME!

Thank you again for bringing this to my attention! I am really, really happy to learn this (guess I should’ve watched the WHOLE video I posted, instead of skipping around, huh? lol :rofl:

But yes, I agree, disabling it should definitely be an option!


I like your “Virtual Wall” idea but love your carpet. Any vacuum of worth would love to be nestled in the star. RE: “Put Me Down!” This isn’t a flying carpet by chance? :joy:

Then there is always the Roomba that Can Fly! (https://www.youtube.com/watch?v=wA2yIVFb2lI) from the other post. . . :rofl:

I agree with you. This is an easy “logic” switch in firmware. Yours is a very good argument for the #wishlist where it may foster a change. :thinking:

1 Like

I’d love to have a software switch to disable the cliff sensors. I followed somebody’s instructions for Roomba to disable them on another vacbot. I first tried to tape white paper over the sensors, that didn’t work, some sort of sensor error. Next I cover the white paper with clear packing tape on both sides, It stiffens it up and make it shiny, that made the difference. I scotch-taped small pieces of that over the sensors and it’s been working for months now.


With my I Roomba I used 3 strips of frosted scotch tape, stacked. Worked. i change it 2-3 times a year.
i have no stairs but throw rugs on hardwood scared it. Some it goes up onto but not off others the other way. But that works for me. BTW, I Robot says there is no fix…