Using Wyze app with PIA


Well, after a month of getting the runaround, I was finally told Tuesday that there is nothing WYZE can do for me. They can’t figure out what the problem is so there’s not a chance in hell they’re gonna figure out the solution. VPN wasn’t an issue with WYZE from Sept '18 to mid-Jan '19, so it should be obvious it’s something they did in Jan. because nothing changed on my end. I’m mainly frustrated at my time and effort they wasted. They could’ve just told me a month ago “Yeah, we put out an update and it’s going to prevent your app from connecting to your cameras if you have VPN active. Sucks to be you”. At least that would’ve been honest. :rofl:

Connectivity Trouble 1/17/19

Which VPN software are you using? I use PIA successfully with all of PIA’s US based servers. Can you connect without the VPN, or not at all?

NOTE: Post edited for thread clarity


I apologize for the confusion. I didn’t discover that my VPN was the problem until contacting support. I am using PIA. They told me yesterday that they were surprised my cameras had ever worked since their system isn’t compatible with VPNs. I switched around to 3 different countries and 4 states to try and get their app to work with PIA but nothing worked.


I can connect immediately with PIA disconnected. When I then reconnect PIA, the app won’t connect to any camera.

1 Like

Well, that’s about what we would expect. Sorry we can’t effectively help with this one. I’m also surprised that it was working!


Check with DreadPirateRush. His are working fine with PIA. Maybe there’s a hidden solution.


Hello, @okiepat2000

There is one thing that I can think of that will prevent your cameras from connecting to your phone’s Wyze app when using PIA.

Go into the SETTINGS of PIA and make sure that BLOCK LOCAL NETWORK is OFF in order to ALLOW it access to your local network (I don’t see it mentioned here).

That has to be allowed in order to connect to the cameras and to your Mobile Data, at least for me on 5 different Android devices (view screenshot below). If I enable it to BLOCK Local Network then my cameras won’t connect. In addition, If I’m away from home and try to connect to Mobile Data then PIA won’t connect to that either until I “allow” access to Local Network.

After changing the BLOCK LOCAL NETWORK setting… make sure you shut-off PIA and then turn it on again (tap on slider bar on PIA).

If you already have your setting to allow access to your local network then obviously this won’t help you.

Fingers crossed that this helps you and other people using different VPNs that have a similar setting.

Unable to connect when on local network VPN

@okiepat2000, @ThreeTen is correct in that I have “Block Local Network” turned off. There is another thing I totally forgot to mention, and may be the magic bullet for you. I am NOT using the latest PIA app on my phone. I reverted to Version, and have refused to update my app because of UI and functionality changes PIA made to the app. I hope that is helpful. I apologize for not providing that extra information before. :slight_smile:


YOU ARE AWESOME! I can’t believe I didn’t think of that. I cannot thank you enough.


There is ZERO need for you to apologize for anything. I would be lost in the dark without your help. Block local network fixed my problem but I REALLY appreciate the heads up on the update. I’ve only had PIA a little over a year so I’ll look into backdating it. I hate it when UI gets messed with because of my OCD but when it hurts performance it gets personal. :rage:

Thanks again for all your help.


I’m moving your original post and the replies to a separate topic.

1 Like

Hello, @okiepat2000

That’s terrific news that it helped with your connection woes :nerd_face:

Remember that if you update PIA’s app in the future to double-check the block local network setting. Sometimes when I’ve updated the android app it reverted back to the default setting which is on (enabled).

You’re welcome… now you can go back to enjoying your Wyze cameras.

Thank you for taking the time to let me know that it worked for you.