Update on Beta camera firmware and

Consider for a moment that by rotating the camera 180˚ you have turned the image upside down, that very result can be had using the ‘advanced settings’ “rotate image 180˚”… Seems you don’t have a problem or, maybe I am mistaken In your need

Big_Monkey, sometimes an installation requires you to install the camera upside down. In this case, you do indeed use the “rotate image” option to compensate. The new driver was failing to take this into account, so that when you drag left or right, the camera panned in the wrong direction. Likewise, when an object moved in the field of view, the camera again panned in the wrong direction.

I am the one who reported this. I haven’t yet installed the updated driver, because I’ve never gotten any feedback from Wyze on whether they recorded these misbehaviors in their bug-tracking database, much less whether they have fixed them or added tests for these bugs to their regression test suite (assuming they are performing basic code development/testing hygiene).

And besides which, I have no use for any of the newer features. Firmware is doing a solid job for me on my inverted cameras.

I have several mounted that way too but I’ve not had the same issues as you mention… Maybe I’m lucky??

Thank you russgoog. That was the problem I was having. But today I did upgrade to and all is well. No issues with inverted motion tracking. Seems to be fixed.

  • Andy
1 Like

How do you find I have a problem? Where do you revert the update from?

To revert firmware when using the beta app, open the cam, then settings, device info, firmware, have problem?, then choose the firmware you want to revert to

1 Like

Are you still having none issues? Did you update pan cam

I finally went ahead and updated. The results?
The good news is that tracking works ok even when mounted upside down (with 180 degree rotation).
The bad news is that I’m no longer seeing a reliable “return to home” behavior if motion tracking is turned on. Prior to the update, if I manually drag the camera to point at some position, and then a moving target appears and causes the camera to track away from that position:

  • the old firmware would, after a suitable pause, track back to that home position;
  • the new firmware remains pointed wherever the moving object left it.
    I find this behavior extraordinarily annoying. It essentially is once again causing me to turn off motion tracking. And the old firmware that worked is no longer being offered via the app. I will need to install it via the SD card.


Yes I updated and so far so good

Sounds like you need to reset my your detection zone

I don’t have a detection zone. I’ve never needed one. How would that help in getting the camera back to home position?

After you set the detection zone, then it also sets the “home” position.

It says “once moved, the camera will return to this position after 15 seconds of idle time.”

One step forward… Two steps back. seems normal for Wyze

Setting a detection zone seems to have done the trick. Thanks for the tip!

1 Like

Spoke too soon. On at least one camera, I set a detection zone and enabled motion tracking – but now that camera never detects any motion. I can stand in the middle of the detection zone and wave my arms wildly, and… …nothing. No motion tag. Move around waving my arms (I look so precious when I do this!) and… …nothing.


That happened to me once. I tried everything including checking all the settings and even restarting the camera without success. I eventually deleted the camera from the App and added it back and restored all settings and activity zones. That has been working fine since then. Good luck


This is so stupid, but I have to ask you, did you perchance walk across the camera’s viewing area as opposed to standing in front of it and doing your dancing skeleton routine :grinning::stuck_out_tongue_winking_eye:

I’ve done all sorts of things, including a Ministry of Funny Walks routine. Nada.

However, what did seem to work is posting this complaint. About an hour ago, I happened to walk across its field of view and the camera finally followed me. I dunno… It’s been ignoring me for a week or two, and now it’s tracking again.

To answer your question I did both things this morning, viz walked across the camera’s viewing area and then stood in front of it and did some dancing skeleton routine. Both worked fine in the camera.