Troubles with new Vacuum mapping

I just received my Wyze Vacuum and was excited to try it out with the new Lidar mapping system. I am less excited now after trying to map the cleaning area 3 times and having the vacuum lose the map all three times. Who has time to shepherd the vacuum around the house (that takes about 2 hours), moving furniture, keeping it from going under sofas, etc, and getting caught in corners, only to have it lose the map and have to start over?

One of the problems is that the vacuum has a very difficult time trying to dock itself on the charger. First of all, it takes a very round-about route back to the charger, then it maneuvers forward and backward and round and round for about ten minutes or so before it will dock. Typically, it will finally place its contacts onto the charge, announce that it is starting to charge, then immediately move away from the charging unit and maneuver around some more, then repeat the process over and over until it finally stays in contact with the unit.

Unfortunately, after it does this, it also erases its map, especially if you stop it in mid-cleaning-mapping and tell it to return to the charger. After it’s done fussing with the charger and finally connects, it ten erases the partially-constructed map.

On one trial run, it ran out of charge and returned (eventually) to the charger, then after it had received enough charge, it recommenced cleaning/mapping, but midway through this session, the map became so corrupted that it could no longer find its way around and started going diagonally across the room in an unrecognizable floor plan it had imposed onto a previously-perfectly-generated map.

On another run (after I had to reset the map), it completed mapping the entire floor, then returned to the charger and fussed around the charging unit for at least 20 minutes backing into the charger, then moving away again, then backing into the charger, then moving away. I finally grew frustrated with it and physically moved it into contact with the charger–and it erased the map it had just spent two hours creating.

So, in my opinion, this unit’s mapping algorithm is not ready for prime-time–and even though the instructions have nothing to say about picking the unit up in the middle of a cleaning session, apparently doing so causes it to erase its map–something that should be mentioned in the instructions.

1 Like

I picked up my vacuum when it was starting to swallow wires and it did not lose it’s map. That gave me just enough time to set a virtual wall. After hitting continue, it resumed mapping. I do agree though that we would benefit from having a separate mapping mode & cleaning mode as well as the option to save different mapped rooms.

Are you sure you didn’t buy a cat?

I tried three more times this morning to create a map, Whenever I stopped the vacuum in mid-session and had it return to the charger, it would take at least six attempts to connect before it would finally stop moving away from the contacts. Then, when it finally would start charging, it would erase whatever portion of the map it had created up to that point. I have about decided to stop trying and return the unit.

Yes, pressing STOP means stop mapping and erase the data you’ve written. Try using the PAUSE button instead of STOP.

1 Like

But then how do you get it to go back to the charger, then? Pick it up and manually place it?

By the way, I just had it return to the charger, and it took ten tries before it would make final contact: move into contact, then move away, then move in, then move away. Ten times…

I’ve tried mapping twice and both times had to stop in the middle of it which corrupted data. Seems odd it doesn’t keep some of the data but instead needs a full round of mapping to save any portion of the house map.
Still excited about the vac and am sure it will get better through updates.
Thanks Wyze. Keep at it.

what type of flooring is the charger sitting on?

1 Like

The charger is sitting on carpet.

This morning, I experimented with pausing the unit and placing it manually against the contacts. It started charging. Then when I resumed cleaning (pressing the Cleaning button), it erased the map and started over. I tried this three times and it erased the map each time when it started cleaning. Is that the way it’s supposed to work?

No that is not the way it’s supposed to work.

if possible, I would recommend putting it on any type of flooring but carpet. Because carpet moves so much it may have trouble docking. I had that issue for quite a while with mine. It’s now on linoleum in my kitchen and is far more consistent and works great.

When you say you pressed the button to start the cleaning, do you mean on the vacuum or in the app? Once it has mapped the room the map should stay until you reset it or (the bug) until it’s lifted and moved for example to another floor. the map should stay in between cleanings and that includes all of your virtual walls that you set up. Once it has been mapped you should be able to click on an individual room once that room is identified in the app and have it only vacuum that room at which point when it’s done it will return to charge.

Just for giggles, try running the Bass from a different floor type of possible that way it can charge itself more consistently and see if that doesn’t help the map stay for some reason. It’s an odd suggestion but weird things have happened. Sadly this release is VERY buggy. it’s just fighting through things until they get the next update out right now.

My Vacuum mapped the entire floor and all the rooms at a 45 degree angle, having initially found a sofa that was at a 45 degree angle. This makes cleaning very inefficient. I will try moving the docking station and remapping.

From what I have learned about the vac in the few days of ownership, the map is not saved until a complete map cycle has completed.
If I want to pause the vac I use the app. Battery life seems to be getting longer because of the lithium ion batteries being cycled.

I will try the ’smooth floor’ trick.

My problem is that it takes about 2 hours to map the entire floor level. It is a pain to shepherd the vac around all of the areas while it creates the maps; but apparently, according to some of these posts, the map won’t be saved unless it has mapped everything (although I’m not certain how it knows that everything has been mapped….) and cannot be returned to the charging unit before finishing since doing so erases whatever portion of the map it has created. That is most frustrating.

By the way, I pause and stop it only from the app.

So, I will give one more try, this time from a hardwood floor location for the charging unit and hope it won’t be another two hours wasted.

1 Like

I wish someone from the company would hop on this thread and offer some advice.

1 Like

I agree I dont know why it cant save a partial map. and then on further runs just update the map. that would be far easier.

and I believe the way it “knows” everything has been mapped is that it only goes along one side. until it reaches the charger again it is still “creating” the map. mine backs up from the charger and follows the wall on it’s right side making one big continuous left turn until it get’s “home”…we basically have the tech version of Nasar cleaning our homes…but with far less entertaining crashes and a lot more wifi.

Yeah my Wyze vacuum had the same problem docking back to the charger. It is put on a carpet. I ended up putting the plastic pad I got as part of my Roborock robot vacuum package under it and the problem was solved. That plastic pad was intended to be used to keep the floor dry when using the mopping function of my Roborock model. I think Wyze can try include a similar accessary if they can’t solve it by software.

The mapping took long time and the robot navigated very inefficiently while doing it. It had to go back to charge itself in the middle because it took too long to complete the map but it eventually got it done. I am hoping that once it is mapped out the navigation will become more efficient when it is doing regular daily cleaning. Haven’t tried it, it is charing now.

Anyway, the Roborock software is much better at this time. I really miss the functionality to customize the room divisions in Roborock.

Well, I’m still struggling trying to get a useable map. I wouldn’t mind so much if I knew that I was being used as an unpaid beta-tester for incomplete software and that there was a way of reporting bugs to the company.

Anyway, I spent an hour last night trying to map the ground floor once again. (By the way, I put the vac on a hardwood floor, and it now docks as expected–too bad the User’s Manual didn’t mention that, could have saved quite a bit of frustration… I notice that the Deebot charger (which I also own) has a horizontal pad that projects in front of the charger and onto which the vac positions itself when docking. I now assume that is to accommodate placing the charger on a carpet). Anyway, after an hour during which it mapped five of the six areas of the ground floor successfully (if somewhat erratically–for example leaving a room it was mapping to go off and start on another room, then return to finish mapping the first room at some random point later, etc), it ran out of juice and had to return to the charger; which it did and recharged itself long enough to finish the 6th area. I thought I was at last on my way to getting a useable map–but no. Because it then proceeded into that 6th area and immediately corrupted the map–basically by copying and rotating a previously-mapped portion of that room by 45 degrees. From which point it persisted in repeatedly bumping into corners or walls, trying to reach that rotated portion of the map (which, of course didn’t exist), until I forced it to return to the charger (shepherding it along by not letting it return to those phantom walls). Then even though I eventually got it positioned directly in front of the charging unit, it could not find it, until I finally turned it off in frustration and reset the map.

I’ve posted this to other threads, thought it would be a good fit here too:

Until they fix the docking issue, here are some tips:

  1. Try putting the docking station on a hard floor. That environment seems more tolerant.

  2. Watch the robot when it goes back to the charger. If it fails TWICE, then the next time it tries just push back on the front of the robot to help it dock. The issue here is they also have an issue where if it fails to dock 3 times it will erase the map.

Hopefully these issues will be resolved soon.

1 Like

I also can NOT get a complete mapping done. I’ve run it 3 times so far… currently it is charging itself in the middle of a cycle. Sure wish it had a way to safe portions of the map, until it fully maps the house. Also hoping that I can add rooms later where the door was closed during initial mapping.

1 Like

I heartily second that request: pause mapping, save the portion that has been mapped, send the vac back to the charger then start mapping again, continuing to build from where it left off instead of needing to start the mapping process all over again. (We don’t all have an hour or two to shepherd the vac around the house, removing obstacles, etc, in one go.)

And thanks for the tip about the unit erasing the map after three failed docking tries…Good to know.