tinyCam Monitor PC Network Proxy issues

I have enjoyed using the tinyCam Monitor Pro to see my Wyze cameras on my Windows 10 Desktop. I have found that the best way (and perhaps only way) to make tinyCam Monitor work is to have the Network Proxy set to “Automatically detect settings” under “Network Proxy Settings”. However, for some reason, my computer keeps switching the settings automatically to “Use a proxy server” with the IP address set to 127.0.0.1 and a Port of 8082 when my camera’s actually IP and Port are set to 125.168.1.250 and a Port of 8083. This happens at least once per day. Does anyone know why this is happening and how to fix it?

Is your router set up to always give the camera the 125.168.1.250 address based on the camera’s MAC address?

I do not believe it is. I will try to do that. Should the Network Proxy setting be set on “Use Proxy Server” once I have changed the router settings and put the correct IP address in? Thanks for your help!