Thermostat won't connect to Alexa

Hello all,
I’ve added the Alexa Wyze skill, given it permission, and when I search for devices, Alexa tells me there are no new devices. Any other tips or tricks that anyone can suggest?

When I installed my thermostat it was added within a few seconds automatically. So if you did a discovery a few minutes later it would say that no new devices were found. Go to “Devices” on Alexa and then click on "Thermostats at the top of the screen. It should list the available thermostats. Mine was listed with a long string of characters as the name, that didn’t match the name I put into the system. You can then change the name in Alexa, or go back into Wyze and update the name and it will change. If it’s still not showing up, not sure what the issue may be.

Same problem here… Any update?

My thermostat appeared in my Alexa device feed the next day. When I opened Alexa on my iPhone it showed that there was a new device, and it was there. I guess I just didn’t wait long enough.

Unlink and re link wyze to alexa and will discover it. Worked for me