Thermostat Scheduling Does Not Work

I set the schedule to turn heat on to 72 in the morning and 70 at night, but whenever I check on my phone, it seems always default to the one in Temperature Preference (which is 67 degrees). I ended it up have to manually set it every time when I check, Anyone having the same issue?

I don’t have that same problem, but you can always modify the temperatures in the Temperature Preference settings to 70 for Sleep and 72 for Home. Please note that whenever you change your Savings/Comfort settings, the Temperature Preference settings revert to Wyze defaults.

In the mean time I would open a support ticket with Wyze and send them logs so they can look into what might be causing the schedule not to apply.

I can’t get the thermostat scheduled to work either. It always just goes to whatever the home temperature is no matter what I have a trouble ticket in.

Same thing here. Parts of the schedule work - it doe the first and last setting, but the two interim one, misses all the time. Set the preferences to match my schedule settings, and they stick (generally) but can’t get the schedule to reliably run. Keeps going back to “home”.

Very frustrating. You’d think this would be the easiest part.

If you are walking in front of your thermostat when it is set to away, it will automatically see you are there and switch to home mode.
If you want it to set a different temperature when you are still home, just set a new home trigger with a different temperature setting. Away should only be used when you want it to detect that you have come home early and auto switch to home mode.

Mine switches from sleep mode the home in the middle of the night and start roasting me.

Speadie, really? Thats the dumbest thing I’ve heard - the detection thing overrides the schedule? Geez.

I only see one place to set " home ", “away”, “sleep”. How can I have multiple homes? And why can’t I just set it to change the temperature at certain times? Why do I have to do the whole home, away and sleep thing anyway? or if they allow me to make new blocks of time, why can’t I name them whatever I want to name them? Anyway, I guess once they get this settled out the rest of the thing works pretty well

But why is it dumb? How should it work? Shouldn’t some things override the schedule?

To your other questions, The temp prefs you see only one of each block is to set the default values for that block. Those blocks are used to build your schedule in the schedule panel. You can add as many of each type to build that schedule and override the temp settings in each block if you wish.

Renaming though I would say is a cosmetic enhancement and probably one that should just live in the schedule. I’d much rather live with static names if they sort out other functions than spend resources on renaming blocks at the expense of the features they’ve promised.

EDIT: As to why you have to use those blocks, it’s because that’s how Wyze designed the controls for the thermostat and schedule. Asking why is kinda like asking why you have to represent temperature with numbers. If you take them out there’s nothing left. :slight_smile:

No idea why that would be, when it is in sleep mode it should ignore the sensor.

I opened a support ticket and the response is like “if you don’t like it, return it” LOL

These are canned responses that I got as well when I submitted support requests about the thermostat. I bounced them back asking whether the first line support person could please forward my ‘complaints’ to the app and device developers to make it better.

While I haven’t had many trouble with the thermostat, there are some signs that it was perhaps released too soon and there are definitely areas where it could use some improvements. With the Wyze philosophy, most things, if not all, can all be addressed with software and firmware updates that I am eagerly awaiting.

I’m having similar issues with my 3 thermostats. I have even tried to just have one schedule, and set always to Home. Have a ticket in have sent logs and routethis tests - no good answers. Have factory reset the devices and reset them up… same issue. It ignores the schedule.

Now it has been a week since my last troubleshooting with no reply from support.

Pretty sad. I have several wyze products - they have previously been great. Not the thermostats. Paying extra since it is running during peak times costing me more.

If not fixed in the next week, returning them.

My schedule is also broke. It ignores my schedule during my home time slow and uses the temps from the temp preferences.