Thermostat keeps changing to "Away" setting

My thermostat is stuck on “Away” every time I change it back to “Home”, it immediately changes back to away. One user is out of the house. I am obviously still here. Any tips?

Do you both have the auto switch setting on in advanced settings? I’m not sure how that deals with 2 different phones… If the person who is away turns it off on their phone, does the furnace stop switching to away?

Mine is for sure turned off. I’m not sure about my wife. I don’t think she would have played with the settings all that much. It seems to be working now. But I had to go in and “hold” the settings to home multiple times.

if she’s turned it on, and yours is off, then it might be working as expected, switching the furnace to away because her phone is outside the geofence area ( I think it’s 4 miles?)