Thermostat Issue, firmware updated, not staying on

Installed today. Connected to wifi, paired and tested with heat and cooling successfully, but actual use, it doesn’t appear to work. I can control the fan. I adjust the heat with the app but doesn’t control the unit and after a little time appears to be off and when back into the control area it is in the off position. I can’t control from the tsat either. Just says my area is 32 degrees and nothing is selectable

If I change to AUTO in the app, it goes back to off in about 15-20 seconds


I had an issue with erratic operation. Like you I went through the set up and testing and then updated the firmware. After the update it worked for a few minutes then shut off. I reset the thermostat, deleted the app, and did the install as if new. Worked fine after that an I have had no issues since. All I can figure is the update was partially corrupted.

Reset a number of times and removed the tstat from the app… I guess uninstall the entire app. But should the wall unit work without the app? Thanks for the reply

The actual hardware should work without the app. It needs to be able to function if wifi is out. Below were the steps I used to get mine up and running. I wanted to make sure there was nothing lingering. Not sure if the phone reboot was necessary but…

  1. Powered down HVAC system for 15 minutes.
  2. Deleted device from Wyze app
  3. Forced stop of app
  4. Rebooted phone
  5. Restarted Wyze app (v2.16.23)
  6. Selected add device and began “as new” install
  7. Completed the install, updated the firmware and the unit is working as expected.

Same thing. Appreciate the reply though

So I installed a 2nd one without the firmware update and worked. Installed the firmware update and doesn’t work. Anyway to go back to the original firmware?

Any firmware rollback Wyze? Or an update?

Have you tried to reset the thermostat and delete tstat device, then setup again. Press tstat dial for 15 sec to reset

Several times but the latest v 1.1.1 still remains