Thermostat ignoring temperature preferences

I’m not sure I understand what you were saying, but here is how I have it set:

Home 72
Away 55
Sleep 65

Each thermostat is controlling a fireplace.

One tells me it is currently 71° in the room, and despite the above settings, the App shows the thermostat set to 70.

The other tells me it is currently 73° in the room, the app shows the thermostat set to 72 as programmed above, yet it’s still on.

What am I doing wrong?!

Default temp swings are 2 degrees with the wyze, I think, so it may run until the temp in the room is 74 when you have it set at 72, and kick on when the temp hits 70. You can change the temp swing (differential) in settings>advanced>differential temp. A larger differential means that the temperature will be outside your set range longer, but it will be more efficient, a smaller differential will maintain your set temperature more closely, but will use more gas.

Normally, I’d expect a 2 degree differential to be off one degree on either side of the setpoint, but it appears that with the wyze, the differential setting is only showing one side of the swing, so you have an actual 4 degree temperature swing when the differential is set to 2, which some people may notice. By setting this to 1, it should emulate most other thermostats that use a 2 degree total swing, at the expense of some efficiency.

The reason one thermostat is heating to 70 is that you have set it up that way in the schedule. as newshound said, default temps are just the default and can be changed in the schedule. Go to the actual schedule and change it. Most likely, you set the defaults on one system after creating one schedule and before creating the schedule on the other system, so one system is using the defaults that come with the wyze, and one system is using the defaults you entered. If you go to settings>schedule> then tap on one of the days/ranges that come up you will see the schedule for that day, along with the programmed temperatures. You can change this day’s/range’s scheduled programmed temperatures from this screen by tapping on them. do this for all of your scheduled changes on the thermostat that is heating to the wrong setpoint.

Yes, I have a schedule. And when it is set to home, which is 72, it’s not honoring the setting.

Of course it’s currently warmer than 72° so I would not expect it to turn on, but the dial always says 70 even though the home setting says 72. And if it drops to 71, it’s not going to turn on because it won’t do it until 70.


Tap the actual schedule for today. Tap This: image

Look at the temperature it is set to.

No, home is set to whatever the schedule is set to, changing the default temperature in temperature preferences after the schedule has been created will not change the schedule, you need to do that manually for each block.

2 Likes

THANK YOU! That is not intuitive at all. Other thermostats I have had have just had one place where you set your home, away, and sleep and then the schedule respects that. It never occurred to me that the schedule would need to be updated manually if those temperatures were changed!

3 Likes

Yeah, it’s a bit more of a pain to change things, but this allows you to have multiple different temperatures for more complex schedules. For instance, I like to gradually warm up in the morning, so instead of shooting directly from my sleep temperature of 51 to my home temp of 65, it goes 55, 60, 65 over the course of a few hours.

After a week I’m about to reinstall my “dumb” thermostat. I’m extremely disappointed (everything else I’ve bought from wyze is great). I found all the settings, and set the differential to 0.5; the temp was reading high, so I found the control to correct for that. Problem: the difference between when the thermostat turns the furnace on/off is around four degrees. I keep running to the wall because “it’s too hot” no, “now it’s too cold.” I bought two of these, and will return one. I’d return the other, but don’t have the packaging.

I suspect the problem is the temperature sensor. Possibly it doesn’t have adequate airflow, so is not sensing the temp correctly. Since the thermostat is pretty worthless at this point, I plan to attempt to figure out where the sensor is and drill holes in the plastic to improve the airflow over the sensor.

I am terribly disappointed in wyze. I’d planned to get a complete home monitoring system, but am now rethinking and researching other brands. Yes, others will be more expensive. But if they do what they’re supposed to, the increased cost will be worth it to me; I’ll chalk up the cost of the wyze thermostat as a learning experience.

I had this same issue. Set my default sleep temperature to my desired amount but middle of thr night myself and kids wake up freezing. My temperature wasn’t matching my sleep heater settings.

I cant believe the schedule, which follows the Home, Away, and Sleep pattern template DOESN’T also follow the set temperature for said settings.

What is the point of it then? Confuse people so they wake up freezing?

I have tried a new smart thermostat in my last 3 houses. ALL of them function properly and apply your default home setting temperature to the schedule. Wyze, I love you. BUT YOU GOT THIS WRONG. PLEASE FIX. PLEASE FORWARD TO PRODUCT / QA.

3 Likes

Your problem is that you set the preferred temperatures after the schedule was created. If you’re just using the default schedule, it is very easy to select a block in that schedule and change the default temperature in that block. what you are asking for makes no sense and would break the thermostat for most people.

Basically, the way to get it to work properly is as follows:

  1. Set your preferred temperatures
  2. Create your schedule that uses those temperatures as defaults, and fine tune the blocks if necessary

But for some reason, you want it to be:

  1. Create schedule
  2. Set temperatures that override the temperatures you set when creating your schedule.

That makes sense, but I never set a schedule. The default program did.

After you set up the thermostat it takes you to the comfort settings to choose your comfort to home, away, or sleep. I changed these settings. Thinking I was preparing my house as needed.

But it did nothing. Its misleading the user experience.

Right, the intent is that you delete that schedule, and then create your own. After you setup temp preferences, it walks you through creating a schedule. If you skip that step, then it uses the default schedule, with the default temperature settings.

I agree with much of the sentiment here. Super frustrating you set temperature preferences but then they are ignored in the schedule, if updated later on. Preferences are largely useless. If you desire to change a preference, it requires you to change it in multiple places. I’ve worked as a product manager before and they missed the boat on this one for sure. Would be better to just eliminate the preferences altogether.

1 Like

Welcome to the user community forum @bertolius!

Agree with your post!

Changing the current functionality (schedules overrule preferences) to one where preferences update schedules is currently on the #wishlist. You can read my post over there.

You can follow the link below, vote for it at the top, and add your post to the bottom to keep it alive and put it back in the recent posts listing.

I’m finding these settings a bit redundant. Why should my scheduling be affecting by some preset values? Might as well not be able to add extra blocks because I’m handcuffed to the preset values.
Should also be able to schedule fan run times to be more useful. I want to circulate air at night when the heating and cooling are turned down and not running much just to circulate air in the bedrooms. Don’t need it during the day.

I have had my thermostat for over a year and it did take me some time to get it where I understood what it was doing and how to manipulate it. Some of the settings are difficult.

What preset values are conflicting with your scheduling?

This feature request has been submitted to the #wishlist by other users. Review the topic, vote for it, and add a post if you like.

Trying to set my schedule the way I want, I’m looking to set my heat for 70 at a given time and cooled to 75. It won’t allow this and keeps changing it to. 6 degree spread. You can have 69 and 75 or 70 and 76 but not 70 and 75

That spread is what many HVAC manufacturers call the DeadZone. Wyze calls it the Minimum Comfort Zone.

It is the delta between the settings that prevents the unit from switching back and forth between heat and cool if they are too close together while the thermostat is in Auto.

The manual states that this zone is adjustable between 3° and 10°, however I have yet to find that setting. It is supposed to be defaulted to 5°.

I am wondering if this is something set by the board logic at the air handler.

I’m going to do some research and will let you know.

1 Like

Thanks. Just for Clarity. I do not have “auto” enabled and I am in cooling mode, but just the same I have to enter a heat target and a cool target in the schedule. Seems insane they would conflict unless you were using auto and the stat had to discriminate heating needs from cooling needs.

I can of course easily adjust the temps for the heating season to get my 70 degrees but it kind of negates having a “smart” thermostat

1 Like