Thermostat fan delay function

Speadie, I did not know that you found another work-around. This is great, and users can get separate fan control and the fan-cycle feature back. Perhaps you can give a step-by-step for everyone. Does it have to be reset, deleted and reinstalled from scratch? Maybe it’s still better to wait for the Wyze fix, so we don’t have to do a fresh reinstall over and over. Like gadgetman said, there might be some other functions that might be affected by programming the thermostat to operate a radiator rather than a furnace. Wish Wyze would fix this and Stage 2 heating ASAP, so workarounds wouldn’t be necessary.

You do have to remove it from the app and reset it, however it remembers most of your preferences and schedules, as long as you skip creating a new schedule during setup. It does not remember the base home/away/sleep temperatures, however any custom temperatures that you have entered in schedules are remembered. It does not remember your filter information or address or wifi password.

You set it up like you would normally, until you get to the last part when it asks you what W1 controls. Then you select radiator, and it will allow your furnace to run without trying to turn your fan on during the heating cycle, but it still gives you manual control of your fan. It won’t work in quite the same way a normal thermostat would, as if you switch the fan out of auto to on, it would run it during the heating cycle as well - a normal thermostat turns off the G wire when W is activated on a fossil fuel powered furnace. But as long as you leave the fan in auto mode when the heat is on it will work as expected.

So, is the consensus that for a forced air/gas furnace, for now, we should set it up as a radiator? Does the AC still work as expected? I’m in between heat and AC right now where I live. I wasn’t going to get it yet, but the best got over me and sitting at my desk is a Wyze Tstat in its wrapped box.

I switched mine to radiator per speadie’s process but not sure I will leave it that way. I don’t like having to leave my fan on auto. I like to turn it to cycle or full on days like today just to circulate heat. For instance it’s much warmer in the south and west facing rooms so the heat won’t come on but I would like to cycle or run the fan to circulate the air to balance out the temps.

You can put it on fan cycle or on, and it will behave like it did when you had it on “furnace”. The G wire may be activated by fan cycle or on when the heat kicks on, so it will either be cut out by your furnace board or it will continue to run during the start of the burner. You don’t lose any functionality by switching it to radiator.

I switched my furnace to radiator and reconnected my G wire so that I can run the fan separately from the heat during the warmer months to circulate the air around, as I don’t have a central AC unit on my house.

1 Like

I have three of the thermostats installed I live in Texas. The thermostats were installed during the ice freeze of early February when so much damage in cold weather stayed for so long. I cannot say that I noticed cold air blowing through the vents when the heater kicked on too late. It probably did but I have not noticed. We are coming up onAir conditioning time. I have had no problems with the three thermostats. Again I did not notice the cold air, but it may be up in there

Until Wyze comes out with their update that promises to fix this, I would suggest the following (speadie, correct me if I’m wrong):

  • If you want to use the fan by itself (or you use the fan cycle function) then use the Radiator workaround.


  • If you just have a furnace, leave the Fan (G-wire) disconnected. That will allow the furnace to control the fan.
  • If you have both AC & furnace, then connect the Fan (G-wire) to the Y terminal of the thermostat, so the fan turns on with the AC (there will be two wires going to the Y terminal). (This is how I have mine set, and it seems to work fine since I don’t use the fan separately.)

I’d put your use case in with using the radiator workaround.
You really don’t want the thermostat to be calling for fan during a heat cycle with a fossil fuel powered furnace. It is going to put extra stress on the blower fan if the furnace spins it up and then shuts it off and then spins it back up 15 seconds later. It can also cause rust issues with a high efficiency heat exchanger to run the blower fan over it before it is up to temperature. The only time you want a call for fan with a call for heat is when you have electric heat. That’s the reason most thermostats have a switch labeled electric / fossil fuel on them.

So in my scenario (as posted earlier) you are saying to go back to how I had it with propane forced air heat rather than radiator? I use the cycle and fan only setting quite often in spring and fall.

Leave it on radiator, it is better for your furnace. When you have it on forced air, every single time your furnace runs, it cycles your fan twice/ runs it when it shouldn’t be running it. When you have it on radiator, it may occasionally cycle your fan or run it when it shouldn’t, depending on if the fan cycle decides to cycle the fan when the furnace is starting up. Doing something bad occasionally is better than doing it every time. The only way you could stop it from ever doing it would be if you disconnected your G wire (this would disable fan control completely on your furnace), or wyze fixes their programming to not run the fan during a heat cycle when you have a fossil fuel selected as the heat source.

1 Like

Thanks guys for your input. I may just wait for the heating season to be officially over, shouldn’t be too much longer. That gives them about 6 months to fix it. Like I said before, my biggest concern is that it appears that Wyze doesn’t even think this is an issue. So until they buy into the fact that this is not how you are supposed to control a forced air gas furnace, then there is no fix in their minds that is needed.

Holy cow - this is not rocket science! It’s taking way too long for them to come out with the fix. They must have Boeing’s MCAS team working day and night…
The real question is how in the world Wyze’s design team didn’t seem to know the basics of how HVAC controllers work in the first place. How could they release a product that turns on the fan (G-terminal) immediately with a call for heat, and then try to fix the problem (four months later) with a 15 second delay? Doesn’t make sense at all. All they needed to do is provide an option to turn off thermostatic fan control and let the furnace control the fan, which is the way most furnaces are designed to operate. This is basic HVAC 101. I think they should be embarrassed. I guess Wyze doesn’t realize that this might be tarnishing their reputation. Or maybe they count on loyal customers like me, who will be happy to purchase a second thermostat (different location) and are willing to wait until they have a version that works with separate fan control and programmable 2nd stage heat without resorting to workarounds. It’s a love/hate relationship, for sure! :broken_heart:

1 Like

Since we have some excellent HVAC people here. I am slated to get a new Heil A/C and propane forced air furnace. Both are two stage. Are you saying that the WYZE thermostat may not support these new items? Or is the two stage the heat pump with electric stage two that have the issue? Thanks in advance. My poor Lennox system lasted 21 years.

If your furnace can run the second stage by itself, then it would be compatible, but as of right now, the wyze does not call for second stage heat correctly. Second stage cooling is different, I have not tested the wyze to see if a call for second stage cooling keeps the first stage on or not.

I set both my stats to radiator this morning. Previously just pulled the G wire. And it works as speadie said. No more double cycling the fan. Clever workaround, seriously.

Though…I do wish Wyze would just fix the G.D. thing to work correctly. But this is a good workaround for now. Unless they find a way to break it…while trying to sell me a desk lamp…

1 Like

Not only are they not embarrassed, but the Wyze employee that works with the Thermostat (I forget his name or I’d @ him) is standing by their claim that it’s a safety issue and they’re right and we’re wrong. They seem to think the 15 second delay is a compromise when they’re just flat out wrong. I haven’t seen any other posts by Wyze indicating that they are even considering fixing it at all since the 15 second delay thing, although I certainly could have missed it.

From what I gather, they seem to be running all “forced air” devices with the same programming, regardless of what energy source you have selected, so it is a compromise/safety thing, because they have programmed it wrong. They should be running forced air with a fossil fuel source differently than forced air with an electrical source, because running an electrical resistive heat strip without the fan will cause the heat strip to burn out / possibly catch fire.
The workaround of telling it you have a radiator is what it should already be doing behind the scenes when you tell it you have a fossil fuel source and forced air.

This is an email I got from Wyze Support on March 17th:
The feature you described is already on our Roadmap and will be released in v1.1.3 firmware. In v1.1.3, we will allow users to select what experience they want: by the furnace, 15-second delay, 30-second delay, and 60-second delay.

We have no timeline yet on when this will be released but rest assured that we are working double-time to get this resolved.

So good news/bad news. They are working on it, but not apparently correctly. Also, we are currently on v1.1.6 so this isn’t even accurate. :roll_eyes:

Also, speadie, my mom’s condo has a 50 year old Lennox unit in her ceiling with an electric heater and the AC condenser on the roof of the building. It definitely has a delay before the fan turns on, which makes our point even more relevant: THE FURNACE NEEDS TO CONTROL THE FAN, NOT THE THERMOSTAT. It’s not up to the thermostat to change the way the furnace was designed to operate.
:roll_eyes: :roll_eyes: :roll_eyes: :roll_eyes: :roll_eyes: :roll_eyes:

Yeah, I’m not sure what I am going to do now. I was going to use @ speadie idea of the radiator setting until he made it sound like it isn’t fool proof and still might kick your fan on during heat cycle when it shouldn’t. What’s the return policy for purchases directly from Wyze?

The only time it could switch the fan on when it shouldn’t is if you had the fan in “cycle” mode or in “on” mode. If you leave the fan in “auto” mode when the heat is on and you have your heat source set to radiator, then the fan will not be operated by the thermostat, and therefore will not come on when the furnace is running.