Thermostat fan delay function

Just updated and tested and it works the correct way now.

According to Wyze: "Added a 15 second delay between fan and heating to prevent cold air from blowing before the furnace warms"

Is this how Wyze decided to fix this? Why was it was decided to override the furnace and force a 15 second fan delay? The furnace should decide what is best. Many furnaces take a lot longer than 15 seconds to heat up. Some don’t require that long. Most higher-end furnaces have their own thermostats and timers. Why not just let the furnace decide? This is still disappointing. I cannot hook up my G wire until this is fixed, which prevents me from operating the fan independently (I have hooked it up to the “Y” terminal so it will go on with the A/C). This is my workaround until this is fixed properly, but it will prevent me from buying a 2nd thermostat from Wyze (unless I install a DPDT switch temporarily for Heat/AC, but then there would be no AUTO function).

You should try the solution @Hookdog suggests:

I would recommend that you take a couple of screen captures to make it easier to restore your schedule and preferred temperature settings.

You get proper furnace operation (no blast of cold air), independent fan control and proper AC operation.

Good idea - I will try Hookdog’s solution (hopefully it will still work with the update), but I still wonder why Wyze tried fixing the problem with a 15 second timer. Both of these solutions are workarounds, and I do not have a lot of confidence in Wyze’s ability to properly fix this, at least in a timely manner.

I guess the question I have is if the onboard function is standard for most furnaces or if most of the ones out there are controlled via the thermostat?

IIRC the 15s delay was to fix systems that didn’t have onboard control and were turning on the blower as soon as the pilot came up blowing cold air for a bit. Still leaves it unfixed for those systems that do have it onboard. My personal theory is Wyze designs for the 80% and situations like yours are outside that and take a lot longer to get added.

Yes, Not sure why they can’t figure out that the furnace company already has this figured out. They don’t need a delay. The furnace will protect itself. They also have a safety delay built in of 2 minutes if you turn off and then turn back on the furnace. This once again is not necessary. The furnace will protect itself and not fire off until it has cooled down. The thermostat is just there to send the signal that it is too cold/hot, it does not need the thermostat to think for it. I wonder what other issues we will find in the summer when we are all trying to use AC?

I used Hookdogs suggestion, but the update seemed to change it back to where it is now starting the fan after the 15 seconds. so frustrating. So I disconnected the g lead again… My issue is compounded because I have a 2 zone system. the zone board seems to get confused and freeze when it is getting all of these fan and heat signals at once. If I disconnect the G lead then it goes back to normal operation

Wyze, we love you, but please hire an engineer from Honeywell or something. You need some additional help.

OH NO - I had a feeling the update was going to screw up Hookdog’s workaround. In order for the fan to turn on with your AC, hook up the G wire (coming from the furnace), to the Y terminal on the thermostat (you might have to install a small jumper because there will be two wires). Nothing should be hooked up to the G terminal on the thermostat. No separate fan control, but the heat and the AC should work as intended. They have to figure this out, as well as Stage 1/2 heat.
Hope the guy from Honeywell gets there soon. :slight_smile:

1 Like

Thanks. You saved me a lot of time and frustration. I was at FW 1.1.1. I was annoyed that I couldn’t upgrade to FW 1.1.2 … kept getting an “upgrade failed” so I filed a ticket last night. Now I know that I don’t want to upgrade to FW 1.1.2. This is not good for Wyze or for us.

Every single gas furnace that I have ever seen controls its own fan during the heat cycle. Wyze is trying to fix something that isn’t broken. All other non communicating thermostats turn off the fan during a heat cycle on a gas or oil furnace because the furnace takes care of it.

1 Like

Interesting, thanks!

I am actually getting the same issue with the upgrade. I can’t do it. It tells me “Failed Upgrade” as well. anyone else?

I also hear you about actually doing the update. I think i resolved my issue using the fix posted above by selecting the ‘Other’ system option so i do not know if i want the update now.

I’m not going to update my unit.

Jimvia76 reported that the 1.1.2 update breaks the workaround that I had proposed by instituting a fixed 15-second delay and then forcing the fan on. This would be no good for me because my furnace needs to run for a couple of minutes before turning on the air circulation fan.

Dgeller reported that he got some of the functionality back by connecting the G wire to the Y terminal of the thermostat. That’s okay if you don’t ever want to use the fan cycling function. I won’t update my unit till I hear better reports.

Any update on this? I was thinking about switching out my Nest for this. But not until all these “features” are fixed.

Nothing yet other than the 15 second delay in the last update. I don’t know why, but for some reason Wyze is being stubborn about this and are apparently think they know better than the engineers that designed the heating system. When Wyze posted in this thread, they still say it’s a safety issue and they are just flat out wrong. If that were the case than you would never be able to safely use any of the 99% of thermostats out there that simply call for heat and leave the cycles up to the heating system. Not to mention that there’s no requirement to even use a G wire if you don’t want or need independent fan control, so for those people Wyze’s “Safety” feature isn’t applicable anyway.

2 Likes

Thanks for the update. Yeah, I read through all the posts about this and I am in disbelief. I am relatively new to Wyze but I like what I have seen and price targets but am a little concerned with all the missing features and future promises at product launch. I’m really concerned that their resident expert doesn’t understand the basics of how HVAC systems work and the fact that cycling a blower motor unnecessarily won’t have any negative impact. I’m an electrical engineer and I do understand the negative impact of starting a capacitor based motor more than you need to, especially within a small period of time. Outside of that, the irony of excessive utility costs to do so when that is the opposite of one of the reasons to use a “smart” tstat. Well, I guess I will just keep an eye on these threads and see if something changes before I would switch out my thermostat.

Hi All,

It is spring here in So Cal, so that means my AC is already back on (it’s a hard life, I know). So far, the thermostat seems to be working fine in AC mode. Just thought I would let you know. This means I now have 9 months of being able to leave my G lead connected. LOL.

I have a 2 zone system with a Honeywell HZ311 zone board.

1 Like

I initially used Hookdog’s workaround with version 1.1.1 and it worked. Before that I had the fan kick on immediately when the heat turned on. Then I noticed my system automatically updated to 1.1.2 and now 1.1.6 and the thermostat is still working as it should. There is a proper delay on the fan when the heat kicks in until it the unit is warmed up (longer than 15 seconds) and I have full fan control even in AC mode. I changed nothing since using Hookdog’s initial work around. I have a gas Lennox Elite system.

I don’t think they’ve fixed this yet. Are you sure that you have your fan (G) wire connected or is working? It sounds like the furnace is still in control. Try to just turn the fan on by itself (Mode: Off, Fan: On). If your fan does not turn on, then the furnace is controlling the fan, and not the thermostat, which is what you want until Wyze comes out with the proper fix, which is a setting to give the furnace control, or a 15, 30 or 60 second delay.

You can just set your furnace up as a radiator during setup. then wyze stops trying to control the fan completely, which is the correct thing for it to do. A delay is not the proper procedure, because the blower fan speed is often different for furnace mode (W) and fan mode (G) Running both W and G at the same time on a fossil fuel powered furnace will give inconsistent fan speeds. Delaying the fan is not the solution to this, Not activating the G wire at all when W is powered is the solution.

I am curious to see if people try were to try what speadie has suggested if this approach resolves their issue, and no other features regress.

I would think that fan circulate and coast to cool would still work with speadie approach since g wire could remain hooked up and I suspect those features are defined in different modes. While in heat mode is there something that shuts the heat off earlier than the fan and continues to blow a little while to get excess hot heat out of the ductwork, perhaps the furnace itself (on certain older units?) would control that just like (when disconnecting the g wire) preheating before blowing (if no G wire hooked up furnace itself must be controlling that delay fan start)?

Sounds like this approach needs to be defined during setup, so it doesn’t sound like user can just go and redefine the furnace to a radiator, but likely have to reset thermostat or remove and reload app, not sure on that part?

If anyone tries this please let this thread know your results?