Thermostat bricked and unable to pair

I’ve had it installed since Feb 2021 with no issues. Wiring is Rc, Y1, G, W1, C.

Las night the app reported thermostat was offline. Display showed a wifi error icon but was able to control locally.

I rebooted the router with no success. Rebooted the thermostat with no success. Did a factory reset by pressing control knob, and deleted device from app.

Now it is unable to pair back to the app. I’ve check Bluetooth and location settings. Tried from 4 different devices, with 2 accounts. Multiple factory resets on the thermostat. Thermostat is now bricked and completely unresponsive. Email support just referred back copy/paste of generic pairing guide.

App was on the beta channel but I’ve downgraded it back to stable. I don’t think the thermostat was on beta firmware, just the latest stable (1.63 or something like that).

I know the pairing is done over Bluetooth so I ran a Bluetooth sniffer during the pairing attempt. Doesn’t detect anything.

I am having the same issue. Were you able to figure it out? I’ve been round and round with Wyze support and their latest solution is to send me a new unit, but that doesn’t help me in the meantime.