Sunrise sunset schedule works then quits

Have set and reset my color bulb to come on and off with the sunset/sunrise rule options. Works for a day or two than not-so-much. Any thoughts? Going to use custom option with specific times that will have to be changed with the change in season. Not happy.

Welcome to the Wyze community sandycoyman. You’ll need to post screenshots of your color bulb’s rules in order for us to effectively help. Need to make sure the screenshot captures complete top-to-bottom of rule/schedule like this:



Above are the relevant screen shots

Your post shows fixed time for start and stop…not sunset/sunrise.

True dat. Sunrise/sunset didn’t work at all, so I switched to the prescribed times which work occasionally. How about giving me the skinny in a step-by-step fashion on how you can actually set both a sunrise/sunset schedule and how you set a specific time schedule that actually works day after day after day. If it’s not possible, please let me know. Thanks.

The “skinny” is that your telling it to turn on and off at your start time. As seen below in the blue noted circle:

You only need the "on"action listed in the rule action if you want something to turn on, as noted in the dialog box next to the ! At the bottom of your screen shot. The color selection, in the purple circle also is contradict info itself. I can’t tell what color each action is telling it to do but the bulb can only display one color, not two at a time.

In final, to make it work I would remove the “off” action, and atleast one of the color selections. Also, if you never change the color or brightness of the bulb, you don’t need to re tell it each rule. Say I turn my kitchen bulb to 75 perc brightness and to blue and I never want it to change, any rule from here on out I only need to "on"action in any rule because the bulb will remember the blue and 75 perc each time.

2 Likes

Good catch! :slightly_smiling_face:

2 Likes

The verbiage provided at the “!” is completely unclear to me as to what it means. To me it says that actions which toggle begin at the start time and the inverse action occurs at the End Time that you program. Actions without an inverse start at the start time you program and then would continue indefinitely.

If it’s trying to say that actions with an inverse only require the “on” action, then it should say so.

Since the bulb comes with no instructions beyond registering and naming it, one is left to struggle with how to set color, brightness and schedule on your own. I’m not sure what you are telling me about the color/temperature/brightness. Are you saying you only need to set the brightness and then the temp and color will be automatically remembered?

You said I retell the color/temperature/brightness rules, yet I have set one rule for each aspect of the bulb, which only seems logical. I saw nothing in the instructions that indicated once you set one of these characteristics the other are somehow remembered.

I will try the schedule with only the “on” command and see what I get. Someone at Wyze needs to write out clear instructions with examples describing exactly what you need to do to program the bulb.

The community forum for the bulb indicates there is a sea of confusion on how to make these bulbs function properly.

What are scenes? What do you use them for and how do you set them up and edit them?

Thanks for you help.

After deleting the off rule and the color rules, color/temperature appears to be holding steady, but light does not adhere to schedule. Some mornings it does not turn off and then if I turn it off manually, it turns back on around 10ish am. Is there any way to get the bulb to actually hold to a schedule?

You’ll need to post another screenshot of your rule(s).

Also, please take a screenshot of the expanded history records associated to your rule: Wyze app Home > Account > Rules > History > expand each section (the down arrow icons). E.g.:

If you only have a start time in the rule, then the listed action will run. If you also have an end time in the rule, then actions with an opposite (opposite of on is off, cameras have turn on notifis then turn off notifs, motion detection etc) will run at that time.

The bulb will remember it’s last color, brightness setting. So if you never change the bulb brightness or color, then each time you or a rule turns it in, it’ll be the brightness and color that it was last set at. If you change the color or brightness for any other reason, then you’ll need to include the other settings. Example, I have a rule to turn my living room bulbs to red if my garage has been open for X length of time (I forget it sometimes), but now say I have another rule to turn my living room on at X time, if I only used the on action in that rule, it’ll be red, but since I want it to be soft white, I’ll have to include the color brightness also.

It’s like a shortcut to a favorite bulb setting that you have saved. If you change your bulb colors and brightness to something that you like, click the “save” above the created scenes line. Then it’ll save those settings to the next in line spot on that line. Unfortunately there is not rule action yet to “turn on X scene” in rules, but it is a requested future feature. The bulbs don’t have to all be the same color and brightness in a scene, that’s just how I have mine set up here:

1 Like

I need help with my color bulb and setting up for sunrise on/off and sunset on/off.

I might be overthinking this but it never seems to work.

Glad to help! Can you post a screen shot of your rule, make sure all actions on the rule are included.

You don’t happen to have both an on and off action in the rule?? That’s the most common oopsy. You only need one or the other.

Hmmm, the double rule might be the issue but it was actually off this morning. Any tips suggested and I’ll see what happens tonight.

Thanks for the photo! Exactly as I had thought. The way rules work is that all actions listed run at the start time that you program into the rule. So you have a on command and a off command listed, both are sent to the device at your start time. You only need the on command in your rule, because you have an end time listed, at that time the opposite of your listed rule runs which is The off action. I would remove the turn off action and save the rule and it should work as you intended.

2 Likes

Done, hopefully it works correctly this evening.

Thanks for the help!

1 Like

Hmmm, none of the Wyze color bulbs turned off.

All following these settings.

The goal is to turn on at sunset and turn off at sunrise.

Hmm, did I have it backwards and now the first screenshot correct?


What does your rules history say for that time? From the home page in the app, click account, then rules then the history tab.

2 Likes

It’s working now, I had it backwards and turning on at sunrise and not sunset. It worked today and thanks for helping me.

2 Likes

Why don’t they just produce some clear instructions on how to program the color bulb?

1 Like