Stuck on "Connecting camera by secure channel (1/3)"

Had the same problem recently. Got 6 cameras and 2 wont come up on my android phone - wont go past connecting to a secure channel - Had access to video events on the 2 cameras but not livestream. Meanwhile all cameras worked well on husband’s phone and we’re both on the same wifi network. Eventually found a tip to update the app on Playstore, did that, deleted the 2 cameras and added them back and this resolved the issue.

I was able to fix this error by clearing the apps cache… I believe it’s due to cached keys no longer being valid and the app not negotiating a new key. Clearly a bug.

I mom was having a connection issue on her phone. However, I was able to view my mom’s camera (that she shared with me) on my phone.

Her phone then needed a software system update. After that, she could view her camera on her phone.

1 of my 8 cameras had this issue 2 days ago and then today all 8 had this issue. I was able to turn them on/off. I was able to delete and setup one of them. Still stuck on “Connecting camera by secure channel (1/3)”.

At around the same time, I added 2 additional satellites and an access point to my network. That somehow messed up the wifi setting on my phone (was my guess).

SOVLED: I turned off wifi. Deleted my old wifi settings. Reconnected with my wifi again. All cameras worked.