Stuck at 3 of 3 Authenticating - Firmware

I am hoping for a new firmware candidate soon to address this problem and/or an android app/back-end server fix. I am tired of running it in black and white mode (Night Vision Mode ON) and in 480p.
I also set a schedule to restart it at sunrise, noon, and sunset.

Right this minute it’s again working just fine. I also had a problem with one of my pan cams going offline yet still recording on the installed SD card and the ability to view livestream. It went offline every day for over a week, and I had to unplug/plug it in to get it to reset, only for it to go offline again! So I tried to MANUALLY re-flash it (even thought it had the current firmware). It did NOT work as planned–I got into a situation wherein I needed to install the cam fresh, BUT when it completed the process it not only retained the current firmware but also kept all of the presets I had made on it prior to this procedure! For the first time in several weeks, EVERYTHING appears to be working as advertised!! I hope that this will continue!!!

Yes, I am still having the same issue with my doorbell alarm cam. No live-feed if you set your cam’s Night Vision Mode to Auto. Wyze just updated its iOS app a few days ago. Also new problems with View Playback of Cam v2: sometimes it records, sometimes it stops recording. It has to be power recycled to go back to recording.

I am starting having doubts about Wyze camera products. They are not working as they are advertised. Maybe Wyze has too many product lines, and in too many things??? Wyze doesn’t focus to make one product well.

Also their customer support group’s sometimes acting clueless. No matter how you explain the problems that you have encountered with their products, they just ignore what you are saying.

Maybe time to look for other alternatives, any suggestions???

1 Like

Guess what, friends? Doorbell cam stuck again on step 3 of 3, getting video data. Still appears to be recording when notifications are triggered, as I did see a snippet of a video recorded 10 minutes ago but NO current Livestream is connecting. FYI, my 5 indoor cams are working like a charm! My vote is that Wyze is experiencing severe intermittent server-side and/or firmware issues with the doorbell cam, as I don’t believe that we all are having the SAME LOCAL ISSUES!

1 Like

I’m at with the same problem…been going on at least couple of months now. I opened up ticket 2174390 because I’m sick of waiting for a solution. They need to know more people are having this problem.

I apologize to everyone who is still experiencing this issue. Here is the latest update on that from today.

Wyze Video Doorbell is getting stuck on 3/3 instead of displaying the live stream
Alright, we have a build that has gone through internal QA and we found a pretty important bug on it. We’re working on fixing that bug and will send it to beta when it’s ready. We apologize for the delay and appreciate your patience with this.


Thanks for the update WyzeJasonJ!
That is great news!
At least we know a beta is coming soon!

I am having that problem and I am using Android

As a new WYZE Doorbell, Floodlight, and V3 owner I am having the stuck at “Authenticating 3 out of 3” issue, after reviewing the forums, it looks as if WYZE has been aware of this issue since late April (over 60 days at this point) and is caused by a “bug” in the most recent firmware.
My recommendation at this point is that all recent purchasers return all of their affected WYZE products, and place an appropriate review on their retailers site linking to this thread, be sure to point out the lack of a timely fix and that as of the current state of the build, WYZE “security” products in no way lends to any form of “Security”, at home, work, or anywhere.

The recommendation of selecting “Night Vision”, power-cycling, etc are truly unacceptable. There are many other competing options available that “work”; i.e. Bing, Arlo, Nest, Ring, and Simplisafe. With the upcoming Amazon Prime Days, I’m sure I’ll find a better option.


Unfortunately this doesn’t help those of us who cannot return our cameras. I’ve had mine for over a year.

1 Like

Could you please list the steps used to create this rule. I’m getting a little lost trying to do it on my own as I find some of the Rule steps unintuitive.
(Maybe until they get this freeze fixed auto-restart may help me stop having to throw out weekly frozen food deliveries that sit out in the hot sun due to no notification from my Wyze DoorBell v1.)

Even with all these added rules, 480p resolution, night vision mode ON, I still get the 3of3 often!

I only can advise on how to do it via the Android app only (not IOS).
Open the Wyze App.
Click the “+” sign in the upper left.
Click “Add Rule”.
Click the “>” next to “Schedule”.
Click the “+” sign next to “Name”, and give it a name like “Restart Doorbell at Sunrise” then click “Save”.
Click “Start Time” and select “Sunrise” or “Sunset” (may have to press “Set Location”), or whatever time you want, then click “Save”.
Leave “End Time” alone (“Not set”).
Repeats: (I let it do it every day, but you can select what day(s) you want).
Now click the “+” sign next to “Add Action” .
Press the “>” sign next to the Doorbell camera.
Tick the box next to “Restart the Camera” then click “Save”.
Now click “Save”.

To view all saved rules, just click the “Edit Rules” button at the top of the screen under the Wyze logo.
Good Luck


Though I switched to a different brand doorbell, it’s baffling to me that this has not been solved yet. They will need to offer some type of side loading method to install any new firmware since connectivity is a big problem on this doorbell.

1 Like

Excellent Instructions!
Thank you very much.
Worth a try.

As a long time cheerleader and believer in Wyze, I’m hoping things get worked out soon but if not may I ask what you switched to and how it compares to the Wyze DoorBell you previously had?
I’m staring at the $85 Eufy local storage doorbell as a possible parachute if I feel I have to bail. Throwing away spoiled Hello Fresh deliveries is starting to get expensive, and at my age I don’t feel like sitting out on the porch for hours in this heat waiting for the FedEx guy who refuses to knock.


I cant say I favor whatever rules your engineering department goes by regarding releasing a bad firmware update, but when you have so many complaints about the same thing, post a firmware release, you roll it back to the firmware version prior to the incident until whatever your fix is gets thoroughly tested and launched.

When a company releases software, sure bugs usually go out and can be quickly corrected. However, with firmware, the live blood of a device, it goes out and you can brick stuff.

I work in the industry and have worked along side engineering staff. This shouldnt be amatuer hour.


Hey so I switched to Blink with the module option. Its the not the best but it works lol. Wyze overall has a great features like the night color feature and Blink does not. Blink is only battery powered which hasnt been an issue yet. They all have their pros and cons but right now Wyze is super unreliable so I’ll suck it up for now but at least I can see whats going on at the door. It just works.

1 Like

Did you get that Blink with or without the $3mo. subscription? If with/without, how is that working out for you compared with your Wyze VDB?

Still on the trial but with the module you can use a thumb drive to record into it locally.

I’m having the stuck on 3 of 3 authenticating problem also…. and there appears to be hundreds of others with this same problem that have posted in the last 3 or 4 months. No help from customer service either.

Wyze must be aware of this problem but is in no hurry, or are unable to fix it. Any recommendations on other Non-Wyze video doorbells?