Sprinkler controller won't pair on Bluetooth

I was excited to get my Sprinkler Controller today. However, very disappointed that it doesn’t work out of the box. It won’t pair with my Samsung S10 to complete the setup.

I unplugged it and plugged it back in several times. It cycles through the numbers indicating it’s in pairing mode. I’ve cycled my Bluetooth on and off several times. I restarted the app wWhich, BTW blows away the picture I took of my old sprinkler’s wiring). Another annoying part - when you restart the app, you have to cycle through the mounting part again (about 20 pages) to get back to the pairing part.

Unfortunately, the only support I see on the web page is through an email form - which I submitted.

Anyone else having trouble? Using S10? Have a fix?

Thanks,
MIke

1 Like

Make sure that you have Location enabled in the phone settings. Without that, it will not be able to pair.

I had a really difficult time keeping it paired while setting it up (Galaxy A51). It would un-pair in the middle of entering my wifi password, but after a couple of tries it did allow me to add it correctly.

Only suggestion I can think of is make sure your BT is not connected to anything else, even wyze band

1 Like

Can you try on a different phone? I had no issues setting mine up

Thank you for your replies and suggestions. So last night, I pulled my old Nexus 6 out of a drawer. After updating the Wyze app, it connected via Bluetooth (without location turned on).

This morning, out of curiosity, I tried vincent’s suggestion. I deleted the sprinkler in the app, and reset the sprinkler. I tried the setup again with my S10 and location on. It connected for a half a second, went to the connect to wifi screen, then back to the Bluetooth “Try again” screen. Then the app crashed (closed). I restarted the app, tried again, and this time it worked.

Pretty flaky Wyze! Why do some devices require location to connect to Bluetooth. I’m pretty sure that’s not a requirement of the Bluetooth spec.

Glad I could find help here, since I haven’t received a response from “Support”.

Unless you want to spend time to wait on the phone for support (which can be lengthy, but it can also be quick and overall phone support seems to be really good), you could be waiting for weeks to hear something back after submitting an email support request. They eventually do get back to you though :slight_smile: But this forum is very helpful, and there are some people who have a lot of experience with Wyze quirks.

There is a post somewhere on the forum that explains why Android Location needs to be on to get any kind of connection. The essence is that Google wants to track you anywhere and everywhere you go so they can send you targeted ads wherever you are. That’s why they push to have everything on, like Location and Bluetooth. And that’s why they seem to have buried this requirement deep into the Android OS.

The last time that new Wyze Lock firmware was released, I was not able to update that without Location turned on. It just wouldn’t work. After deleting and resetting the Lock and reinstalling the App and everything, I found a note on the forum that suggested Location should be on. It would really have helped if the App would see this and notify that Location is turned off.

But once a device has been set up and added to the App, you can turn off both Bluetooth and Location on your phone, so that’s what I do. When I added the Sprinkler Controller a couple of weeks ago I had forgotten that I have Location off, so it’s something to keep in mind.

Also, browsing the forums I’ve seen that Android 11 may not (yet) work as expected in some cases. Android 10 seems to be the sweet spot for right now.

I’m not sure I buy that it’s an Android thing. My old android phone paired without location. Granted, it several versions old. However, my S10 pairs to other non-Wyze devices without location. I still think it’s Wyze’s implementation.

That’s totally possible. I hate cell phones and have little to no knowledge of what they do and how they work, but the code snippets that were in the post looked legit showing that everything was required to build a connection. I’m not sure for which version of Android that was though, but since Android 11 seems to be a problem for the Wyze App, they probably have to program in a lot of checks, based on which the App handles requests differently. That’s why I’m glad I’m not a developer :smiley:

Well, they finally responded to my story request. Only 11 short days!!! :roll_eyes:. I’m really disappointed in your support, Wyze!

At least they got it right. You have to turn on location for bluetooth to work.

I’m having a pairing issue with an iPhone. Location services are on. The wyze sprinker never goes to the orange flashing/scrolling numbers, but just straight to blue flashing/scrolling. If I hit & hold reset, in about 8 seconds the numbers will all briefly light up orange for a couple seconds, briefly turn white, then go back to scrolling blue. I don’t think it is entering paring mode. E-mailed Wyze…rather not wait weeks for reply