Scheduling on Wyze Bulb - Broken?

I got a new Wyze Bulb and set it up. Awesome bulb. Setup was smooth (except I had to turn on my mobile data for it to connect to the bulb). Now I am trying to do some automation, but haven’t had luck.

I am trying to set it up so that the bulb turns on at 7:00 pm at night and turns off at 7:00 am in the morning. Simple.

I created a rule to turn off at 7:00 am. Every day. So far so good.

I created another rule to turn on at 7:00 pm. But “Every Day” is not quite working for this rule. I check all the days checkboxes and then tap “< Edit Rule” (tap Back - There is no Save button as such).

It goes back to show me the two rules. I click on the turn on rule, and all the checkboxes are unchecked. I repeat, the same thing happened.

Also the bulb does not turn on at 7:00 pm.

I deleted the rule, recreated it, Same thing.

What am I doing wrong here?

1 Like

I just tried to do it with mine (to see if I could replicate it), and I get the exact same result for the turn on. When I set it up it looked like it saved, but it did not say every day. When I clicked to check the settings, all the days were unchecked. I rechecked the boxes, and same thing. It didn’t stick.

Might be a bug. Are you on the beta app by chance?

I would reach out to Wyze support.

Thanks for the verification @towelkingdom.

No I am using the app from the Play Store. In fact I just updated it. I don’t think I was having this issue with the older version that I had before. I was able to set it up there. I just didn’t test it with the older version. Seems like a regression.

I will contact support.

1 Like

By default the scheduled action will occur everyday. So haveing nothing checked is “everyday”. Seems backward to me also to where you should have all checked if it defaults to all, then uncheck the days you don’t want the schedule to run. But I just made a rule to triple check and unchecked does run every day.

I will say, that in the app, the schedule to turn off every day shows on the menu everyday. But it does not say that on the turn on schedule. I’m not sure what the OP shows but he indicated that the schedule to turn on isn’t working for him. I’m going to try to grab screenshots of what I see on my end. I may leave the schedule on, to help OP test, so if it’s an app issue I should be able to replicate it.

@Omgitstony From your screenshot I don’t think you can imply that all unchecked means everyday. When you create a new rule, it has all the days checked by default, and I think that’s what it is referring to.

Nevertheless it doesn’t turn on at the specified time and I am thinking it is because all days are unchecked.

Funny thing is that the other rule which happens to be the first rule created (turn off at 7:00am) has all the days checked and they stay that way. It is just the second rule (turn on at 7:00pm) that is not working. I am thinking a third rule will have the same issue but haven’t checked it.

1 Like

I THINK it’s an issue with the time being PM versus AM.

I went back to the turn off schedule, changed the toggle from pm to am, rechecked the boxes, and the setting stuck.

I definitely think it’s a bug.

@WyzeGwendolyn

Can you forward this on?

I also took the “turn off at 7:00 am” rule where it was sticking, and changed it to “Turn On at 8:54pm” rule and the checkboxes went unchecked on that rule too.

So it could be am vs pm thingy as you mentioned @towelkingdom.

1 Like

For testing I made this scheduled rule. Clicked new rule, scheduled, device (kitchen light), turn on, then the below screen showed up with no days checked. I did nothing else and hit save and the rule ran when the time occured. I also did the same again but checked each day of the week this time . Let the time occur and the rule ran. Went back into the 2nd rule and all days were now unchecked.

I edited the pm rule to now be am, checked each day, exited the rules, reentered the rule and all were still checked. Edited again to change the time to pm and exited. Reentered the rule and now all were unchecked. I’ll agree on the bug. Nice find! Until a resolution is found, just know that all checked, and all unchecked means everyday.

Android 10, pixel 3, Wyze app 2.12.35

1 Like

@Omgitstony
I could swear I tried it several times before it never turned on. After reading your post, I decided to try it one more time, and boom it worked. I did not only rely on the app showing me the status , lest it is an app refresh problem, but I was physically looking at the bulb too.

Oh well, so it is just a cosmetic issue of it unchecking all the boxes which in effect means “every day” but it is doing it only when time is pm but not when it is am.

1 Like