Scale S reads one person %, but not second user?

Is this a common or known issue with the Scale S?

It reads me weight, bodyfat…but only reads weight for my partner.

If it’s so common, are they fixing it?

I am the main user and it is yet to read me. Swapped batteries, tried after shower to have moist feet. Stood on wet paper towels before getting on. Put hard plastic sheet between my legs to make sure knees or thighs did not touch. Deleted device. Pressed reset. Set app back up and still will not read me, my wife got a reading a couple times but very intermittent.

I have submitted a trouble report for my case.

Just went thru this issue when my wife tried to get her BMI. We finally figured it out. I set up the scale and am the “owner”. I then added my wife, she accepted the invitation.
The second person (or others after #2) will have to go to gear icon > user > then click on their name / email. Then on the Account Info page, they’ll need to add their Year of Birth, gender, & height in order for the scale to calculate their BMI. That is the issue most likely. So it is actually trying to calculate BMI, but b/c this info isn’t tied to that particular profile, it can’t.

1 Like

YOU NAILED IT! Many thanks. That was exactly the solution.