Rules triggering late

I have a number of simple rules that turn cameras and plugs on and off. I don’t use an on and off time in each rule. I use one rule to turn on, and one rule to turn off, for each device. The rules are triggering up to 16 minutes late. Consistently late, but not to the minute. For example, a rule to turn on a plug may trigger at 8:14pm or 8:09pm or 8:16pm, but consistently late as the rule is for 8:00pm. This happens both for an ON rule or OFF rule, for both cameras and plugs. The rule histories will show these same times. They just trigger late. Any ideas?
As a side question: Do the triggers come from my Android phone to trigger rules? Or are the rules stored in the cloud and get triggered from the cloud?
Thanks

1 Like

Came here for this problem for it happens to me as well.

1 Like

Not to long ago, there was something going on with Wyze Servers which was getting delayed. I eventually restarted my Camera’s via the App. I also restarted the V1 Bridge by removing it and then plugging it back in. My rules seem to fire on time or within a few seconds. You may want to try this.

It may be worth it to contact Wyze and see if they are experiencing issues with Rules and their servers. Some thing to try.

By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Or online: Wyze.com/support

phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

1 Like

Thank you for your time to reply.
I ran a test rule on one cam with a reset. Another cam without a reset. Both rules were set to the top of the hour. 12:00 pm.
Both rules, each on a different cam, were late.
Just to confirm, I changed the rules and tried them again, within a few minutes. Now set to 12:11 pm. Well, both rules fired exactly on time. I didn’t have time to try the rules at 1:00pm (top of the hour), but I have a suspicion that the rules don’t like zeros in the times setting. Because a test rule run on one of my plugs did the same thing. Works on a setting without zeros for minutes. So, I changed all my rules to fire a few minutes before the top of the hour and I’ll see how that goes. If I’m on to something, I’ll report back. If not, I’ve gone mad.

1 Like

By changing the times and omitting zeroes, all cams and plugs turned on exactly on time this evening. So the solution I see is I can’t put in times with zeroes in them.

3 Likes

Thats great. I must have misread this. Sorry about that. I did an extensive test on the Rules and the delays. I have found that setting the rules at the top of the hour is causing the issue. I decided to setup one rule to turn things on and another to turn things off. but never on top of the hour or at the half hour.

This was my original topic on scheduled rules:

I just created a rule to take a short video clip with:
a V2 at 4:01pm, it fired off a 4:09pm
a V3 at 6:01pm it fired off at 6:11pm.

not good.

Interesting. Have you tried 1 minute before?

I don’t have rules to trigger Camera recordings. Mine controls the lights, notifications, and Motion Detection

I had better luck when I did not use any zeroes in the time.

1 Like

I am having the same issue. I have 4 plugs and they are consistently late. The only one that is always on time is the one set to 9:44. The rest were set to either the hour or half hour. I just changed them all to have no zeros in the minutes. We will see how it goes. Very much appreciate the testing and letting us all know the results. Almost went with a different plug because of this.