RTSP Tips and tricks. Desktop Viewing, Password Protect, Recording, and more

If that configuration doesn’t work try the following:

Put the receive buffer to max (20MB) this should help some with any choppiness you may be encountering. Also use separate UDP ports for each camera… i use 7100 and 7200 for my two Wyzecams.

2 Likes

Are you a phone tech?

Used to be. Now a web wheenie.

Siemens?

Just a caution to all who install the special firmware that enables RTSP. Be aware that this is a separate branch of the firmware that will not be maintained with the standard feature updates. That is features like “Person Detection” may never be available with the RSTP firmware.

As published by Wyze in response to a question by Matthew LinkToSource,
“We don’t have the resources to keep developing two branches of firmware for Wyze Cam v2 and Wyze Cam Pan. This means that the RTSP branch will be upgraded infrequently. Using the RTSP firmware will prevent the camera from supporting any future functions or features in the Wyze App.”

Hopefully, in the future RSTP will be added as a feature to the standard firmware and you can migrate back to the standard set.

I too am having difficulties with connecting via Blue Iris. I’ve used RTSP cameras before and have followed all of the suggestions in this thread for Wyze pan cam but still not connecting. Any ideas or things I should check?

I am not familiar with Blue Iris as I use Apple’s Home app bridged through a raspberry pi using Homebridge software. Sorry I can’t help with something I am not aware of. What I can tell you is that if you copy the RSTP link into VLC and it displays then the camera is producing the stream and the problem may be with your Blue Iris software setup.

Try upping the receive buffer setting.
Also, check your ports are set correctly (554/8999).
As noted before, enable rtp/udp and make sure each camera has a separate port.
I haven’t had time to play with it in a while - maybe this weekend. I’ve got 6 more Wyze cams still int the box I’ll flash with rtsp and see what I can get running stable.

1 Like

I found the best way and easiest is to get streaming on all my devices ( I use actiontiles-smarthings as a dash board to have everything in one place) is the rtsp firmware and use MotionEye. it converts the rtsp to a http and assigns port automatically. I use hassio that has a MotioEye server running on it.

1 Like

Everything works fine, Now I’m trying to stream Wayz Cam v2 to my LG smart TV did anyone have a successful experience in this? thanks!

if you do this. I believe in the future you won’t receive firmware of software updates.**

FYI: I’ve managed to stream my WYZE to YouTube using OSB Studio (free). (I couldn’t get VLC to work at all?!?! Not sure what i was doing wrong. )

I can stream my camera to YouTube via OSB, and cast it to my TV so I can see what is going on in the front street while i am in my office. Works well enough, but there is about a 4 minute delay, and my computer is old, and isn’t really up to the task.

If anyone has any suggestions as to how I can get VLC working that would be great. OSB is too much for my puter :grimacing:

3 Likes

Does VLC itself have a watchdog ability to use this workaround, if I’m using VLC to livestream an RTSP feed?

Thank you Mr. Kelley! I spent hours trying to get my rtsp working again and this config was magic!

1 Like

I suppose I’m having a similar problem to many of the Blue Iris users, except I’m using an Amcrest hardware NVR.

I installed the RTSP firmware on my V2, and was able to get the RTSP stream added to my Amcrest NVR. However, the stream seems to just freeze after 10 minutes or so and to get it working again I have to go into the camera and disable/enable RTSP.

I’m hoping any newer RTSP firmware will solve this issue. I predominantly use Amcrest cameras at home, and I would like to add my existing Wyze cameras to the Amcrest NVR for live viewing/monitoring, and also to have everything recorded on a local HDD.

I am very interested in using RTSP on the Wyze camera and studied the how to at

But reading through this long thread I am confused about the current status. So I would like to ask some up-to-date questions.

  1. Which is the correct beta software version to download for the most trouble free RTSP?

  2. Are the stuttering, etc. problems solved?

  3. Is it now possible, with RTSP installed, to view the uninterrupted stream on a PC?

  4. Is it now possible to set up motion activation and recording?

Thank you.