Robot Vacuum firmware beta test 1/6/2021

I have also noticed that we have multiple closet doors that are sliding full length mirror doors and the vacuum has an issue with thinking these areas are open when in fact they are not. I have had to put up virtual walls to block the vac from trying to go into these “closed” areas. The problem with this is, that I have two full length mirrored doors that are at an angle to the normal horizontal and vertical walls and I do not see the ability to turn the virtual walls or create virtual walls on an angle to block these areas from the vac.

I deleted the device and reset the vac back up and was attempting to remap the whole house and the app is stuck displaying the vacuum is cleaning at 56% charge when vac itself has stopped and went back to dock to charge. I unplugged the dock to force the vac to run dead and the app still says it is cleaning at 56% even after Force Closing the app. The only option I see at this point is to u install the beta app and start everything from scratch.

I got this update email yesterday, definitely some firmware flakyness.

Notes for Wyze Robot Vacuum

We have temporarily paused additional shipments for Wyze Robot Vacuum.

We’re currently working on a firmware issue that can prevent setting up Wyze Robot Vacuum after a certain date in the near future. If you have your Wyze Robot Vacuum in a box somewhere at home, please set it up as soon as possible to avoid being impacted!

We’ll pick up where we left off with shipping orders once a firmware update is ready to address this issue. We’re optimistic that this will be ready in the next few days.

Yea, I think the bigger problem is in the ability to connect the WRV to WiFi, seems to be WiFi designs that were not taken into consideration possibly some mesh designs (all assumptions). They even sent out a survey in regards to the issues seen with connecting the device to WiFi as well.

Which leads to the other assumption that those trying to get the beta firmware cannot because WYZE has pulled it.

1 Like

I just got prompted for the new firmware (finally). It’s now 1.6.95. I can confirm that map editor is now there, yay!


That’s great! I don’t see the update yet, but hopefully it will let me download the new version soon. Anything else new other than the map editor?

Nothing else that I’ve noticed yet. The link to “what’s new” still goes to the .75 release.

Mine prompted - updated - room editor - yay. Will check a room shortly that was getting a brief peek in the door and then done, without actually getting through the room.

Ok, so is this is a beta release. I don’t have that. Hopefully the stable release comes soon. :smiley:

Yes! Just got the beta 1.6.95. First time I’ve had the map editor. I see what people mean about needing outside wall to split a room. Has the warning always read “The splited room is too small”? Is that Olde English or a derogatory adjective?

I reset the map because it appeared as if the vacuum had gone through the back wall and into the yard. Was happy to see the new Quick mapping option. But seems to have more of a problem with mirrored closet doors now. When mapping just keep going back and forth. When I sent it back to base, tried to go through closet as opposed to back out door it used to enter. Anyone else have/resolve mirror issues?

1 Like

I too am having issues with mirror doors that mess up the mapping process. I reran it today with some paper covering the base of the mirror. At least the map will be correct, not sure how the regular vacuuming will be.

1 Like

Same issue with mirrored doors and had to put up virtual walls to cover them. Ghost maps still getting overplayed my previous good map and no way to save and recover a previous good map requires me to reset the map and start all over. Running current beta vacuum firmware and current beta app.

1 Like

I installed the latest firmware, and ran the vacuum to clean the room. I had a virtual wall that I created previously that would prevent the vacuum from going under the couch. Before the virtual wall was set up the vacuum got confused and stuck. I added the wall the previous firmware and never had a problem. With the latest it tried to go under the couch. Not sure why it was ignoring the wall. I extended the wall and see if it happens again. Any thoughts?

I think I read in another thread that if you delete the clean record that has the ghost map it will fix things. I have not tried it myself as I have not had a ghost map issue since my last rest and full map.

I have cleared the map multiple times and had to clean the entire floor to remap it, put up my virtual walls, separate out my rooms the way I want them and then try it again and the ghost map or the charging station appears in another room altogether. There should be a way for us to save a good mapped floor and in fact save multiple good save mapped floors if your home is multi floored and you are using one vacuum for the entire house but want to take it from floor to floor, i.e. 1st floor map, 2nd floor map, etc.

1.6.97 is out

My map got wiped out…

Same here. My scheduled runs completed last night and now my map is gone. Was this a result of the AWS issues Wyze had?

Go into the map editor and change a room name. Map will reload.