ROBOT VAC - Bug - Can't reliably delete no-go zones

Create a no-go zone, save and…it’s there.
Go back and delete the no-go zone, it’s usually gone initially, but reappears after closing and re-opening the vac, or restarting the app.
The only reliable way I found to delete a no-go zone was on a vac with multiple floors setup…
Once you delete, change to another floor, and then reload the original floor. No-go zone should then be gone for good.

Vac Firmware 1.6.173 as well as 1.6.202
Android App v2.32.0 (154)
Android 10 and 12 tested.

Not having that issues on my iPhone. Try cleaning app cache in Account > App Settings

Yeah, tried clearing cache already, didn’t help.

Next step is try uninstalling the app and reinstalling it.

Tried un/re-installing the app on Android 10 and made no difference, other than now I can’t even add new no-go zones at all (on either Android 10 or 12). My maps are pretty old though…wondering if I’ll have to delete everything and create new maps. Really trying to avoid that though as I have them tweaked pretty well.

Any Android users having this no-go issue too?