Reposted - Please explain WHY "Your device isn't compatible with this version."

support

#1

Note: I’m not sure what happened on the website. This message posted once, then I tried to edit it a few times and then it wouldn’t show up in the message listings so here is a re-post.

I have a Samsung S4 cellphone and the WyzeCam app worked with this cellphone perfectly fine up until the last firmware updates were released. The last firmware updates that were released “broke” the functionality of the camera’s ability to play recorded clips. So, I uninstalled the WyzeCam app from my Galaxy S4 phone in an attempt to install the latest version of the WyzeCam app. Well, when I did THAT, the Google Play Store refuses to install the latest version. I get the message that “Your device isn’t compatible with this version.” Well, okay, then why did you even allow me to flash my cameras to a later version of the firmware knowing full well that the latest application would be incompatible with my device? That’s something you could have checked prior to telling me about newer firmware versions.

I get it. Firmware versions of the cameras are independent of the device it’s being viewed on but, none the less, the WyzeCam application runs on specific individual devices. So you could have checked my device and not even showed me that there was a later, incompatible with my device, firmware that is incompatible with the latest software on my phone.

There are obviously “older” versions of the WyzeCam application software that work with my phone. Why don’t you offer a download page for those “older” versions that are compatible with my device and my camera’s “currently flashed” firmware version?

In other words your software could easily see that my device isn’t compatible with the camera’s using the latest firmware and offer to download an “older” version of the application that does work with the firmware.

But what features are you guys offering in the latest WyzeCam application that can’t be exploited on a Samsung S4? I’ve heard that Lollipop is mostly cosmetic changes anyway. So, I’m confused about what makes my Samsung S4 device so incompatible with the latest version of the WyzeCam application when it has worked perfectly fine in the past. Up until the release of the latest firmware updates.

I’ve been without my cameras for 2-3 weeks now. I’m thankful that I don’t live in a high crime area. I have no way to use these cameras unless I downgrade the firmware’s just to be able to install an older version of your software. But if the Google Play Store doesn’t fall back to compatible versions for a given version of firmware, I’m not even sure downgrading the firmware is a solution at this point.

I need some serious advice on how to proceed.

Thanks for reading!

Oh, I almost forgot a very important piece of data. My “Android version” is 4.4.4 (KitKat). So is your software refusing installation because I’m not on Lollipop 5.0.1? I know that some carriers updated their customers S4’s to Lollipop. But T-Mobile never did, for whatever reasons. I’m one of the lucky ones I guess!!!