Recording locally only (SD cards), but cams still trying amazonaws.com

I have my cams set to record locally only, on SD cards. I’ve noticed that my cams are now trying to contact wyze-device-alarm-file.s3.us-west-2.amazonaws.com, sometimes dozens of times in a row, multiple times a day. This started around November of last year.

I have all “cloud” settings disabled, so why are my cams trying to connect to AWS? Is there any to disable this (beyond blocking it on my network)?

1 Like

Your cams require access to internet to initiaize whenever they come online for the first time. This means when they initially connect to wifi after powering up or losing wifi connection, if I understand the way they work correctly.
If they are repeatedly accessing the Wyze servers you may be having some type of connectivity issues, which could be your WiFi setup or a cam problem.
If you can’t resolve this I would suggest you Open a Wyze Support Ticket. They can run an app which can analyze your network and help determine the source of the problem.

1 Like

I understand why the cams would need to connect to, say, api.wyzecam.com. But why that particular AWS domain? And, more importantly, why, if I’m specifically not using the cloud services?

My understanding is that ‘using the cloud services’ is when you subscribe to the CMC or, as is the default in the app, access the included 12 second event videos. That is a part of the Wyze package, bundled together.
The only way I know of to completely not use the services is to initialize the cam on wifi, at which point it will access the servers, then disconnect it from Internet access or wifi, but not power. It should then continue to record to your SD card until it again loses power.
The only way to access this video is to either remove the card to an external PC or to reconnect the cam to wifi and go back online thru the app. I think then that you can use the View Playback feature. This all assumes you have an SD card installed.
Hope this helps -and that I,m correct about all this. I have researched this but not actually tested it on my own equipment.

1 Like

I have done many tests doing this and the most recent was last week, your advice was spot on. The key is do NOT lose power.

2 Likes

Thanks! I appreciate the verification!

1 Like

Since the day I bought my cameras, it was my intention to record only on SD cards, no cloud. And this is what I’ve been doing. When I need to retrieve video, I can either physically pull the SD card and copy the files, or I can use the app to save a video to my tablet.

The only change I’ve made recently (per advice from Wyze support) is to disable both Event Recording > Detects Motion & Detect Sound. Having both of these settings disabled prevents the cams from attempting to contact AWS. IMO, this is a counter-intuitive label, since I do, in fact, want the cams to detect motion - I just don’t want them to send my personal videos to somebody else’s server.

And, from what I can tell, this change only became necessary as of Nov 2019 since that’s when the cams started contacting AWS servers even for those who thought they were only recording locally.

I’ve lost power multiple times. For the most part, when power is restored, the cams come back online with the same config as before. Once in a while I have to restart a cam after a power failure, but I’ve never had to re-config anything.

I remember that the advent of and changes to Person detection caused some big changes in the way Detection was handled. Initially with Xnor it was done in firmware but now as I understand it, it is handled cloud based by Wyze. As I recall that was around the end of last year.
I am really surprised to hear that you have lost power and your cams have come back online without internet access. Configuration should not be an issue since that data is on the SD card but, as we discussed previously, they require an initial server contact to reinitialize after a power loss.
Maybe we are using different terms for concepts here, @Jason21271 - any comments or insights?

The first time I tested this issue was back in October, I know firmware from then on would cause recording to stop after loss of power until connection happened again.
The switches for Event Recording -> Detects Motion and Detects Sound only affect cloud recording that is why they had you turn that off. The only section that controls SDcard recording is Advanced Settings -> Local Storage -> Record continuous or Record Events. I don’t believe the Camera ever recorded to SD upon a Sound Event but I will admit we are going into areas I know less about and may have to run some tests.

1 Like

To be clear, I’m not saying that I operate my cams without internet
access. That’s how I watch the videos with my tablet. I just
wasn’t (intentionally) sending any info to AWS. To my knowledge,
the cams need to contact api.wyzecam.com, and not much else.

I don't follow these boards closely.  I was vaguely aware of some

issue around “AI” changes, but I assumed that didn’t affect me since
I’m not trying to recognize people/faces, I just want the cams to
record when the pixels change, which I assume happens in-camera.