Real Time Streaming Protocol (RTSP)

launched
#636

I had the same type of issue with the last release. My setup is the same as yours, I am using MotionEye to connect to the V2.

Since the new firmware, my camera has not lost it’s connection and every time I look at home assistant the camera is online and working properly.

#637

Thanks for this release! Connection to BlueIris appears to be much more stable now (with hardware acceleration disabled).

#638

I continuously have my V2s disconnect in Blueiris. They’ll come back, most of the time. Outside of HW accleration, anything different when setting up the Camera? Are you using Wyze template within BI when setting up the camera feed?

#639

I have mine connected with ispy and I never lose connection with v2

#640

I have 2x Wyze V2 bought within a month of each other about a year ago. Both runs latest RTSP FW and connected to Blue Iris. The setup for both on BI is exactly the same as I clone the first to the second (only changed the IP address).
One camera had been running solid for 5 days now. The other seems to have exactly the same problem that you’re encountering (BI keeps losing connection, but the camera somehow restarts by itself and works again). The failure had been like that since the original RTSP FW (so, it’s not the updated FW that’s causing the issue).
Overall, the latest beta RTSP FW is much better than the previous one. It is now very much usable (no video stuttering and solid @ 15 fps), except for the one camera that doesn’t work.
So, I don’t think it has anything to do with BI setup or LAN bandwidth, etc. It seems to be Wyze hardware-dependent. If it works, it works good. If it doesn’t, it just sucks. And just luck that I have one works and one doesn’t. BTW, both seems to work fine using the Wyze apps. But I haven’t used it much since getting the RTSP FW to run with BI.

#641

Will pan/tilt control for the Wyze Cam Pan be available in 3rd party apps like Blue Iris in the future? (Or is that already possible with this RTSP firmware?) @WyzeArthur @WyzeGwendolyn Thanks!

#642

I’ve got 2 WyzeCam V2’s and 5 other cameras. All were on a Ubiquiti Unifi AP and the WyzeCams were dropping out every few minutes. I moved the WyzeCams over to an old TP-Link router by themselves and they’re much more stable, only dropping out a few times per day.

Strangely, as soon as I turned on RTSP, my WansView camera started dropping out every few minutes until I got them on separate access points.

#643

it’s already possible according to people further up this post

1 Like
#644

To follow up on this, I upgraded to Home Assistant 0.93 this morning and my streams have been good as gold in HA. I took a look through the changelog and see they’ve altered a timeout for ffmpeg cams. I can’t be sure this is what helped but it looks like a likely suspect as with the V2 RTSP firmware the streams worked reliably in VLC, with HA just dropping out sometimes

Thanks to kind and knowledgable folks of the community here and big thanks to the folks at Wyze, front of house and back, that go the extra mile or 10 to deliver what customers ask for. If these streams hold up to tomorrow night I’ll finally be ordering those few more cams I’ve had my eye on!

Update: Still solid. Cams ordered!

#645

I see where @jkronos says “It seems to work fine as well on my blue-iris setup” but it’s unclear if pan/tilt control is working in BI or just the video stream. @jkronos could you clarify?

#646

Hello, apologies I have only tested on the regular v2 version. It`s been online for last couple weeks but I will be testing a PAN model very soon and will share the results here.

#647

I haven’t heard of that being added in at this time. Thanks for asking!

#648

RTSP is only a protocol for streaming audio and video from something. It doesn’t allow for any way to control the camera, which is what you need to be able to do something like control pan/tilt.

In order to allow you to pan/tilt, Wyze would have to either support a protocol like Onvif that allows for control, or put up a web interface on the camera that allows that kind of control. Either way, it would be some nontrivial extra work.

1 Like
#649

Makes sense, thanks for clarifying, @InnocentBystander and @WyzeGwendolyn.

1 Like
#650

You’re welcome! :slight_smile:

#651

I’m very interested in using the Wyze V2 with Zoneminder. I have a pair of V2 cams, one of which has been flashed with the beta FW that supports RTSP.

Does anyone know what the settings might be to use the V2 in Zoneminder?
Or, could someone please tell me the RTSP path string to use?
I tried the one that the Beta app generates but it doesn’t seem to work- there’s no port parameter (which I think is needed) and none of the many, many, many settings I’ve tried in Zoneminder work.

Any assistance would be very welcome, and thank you.

#652

just wanted to say I flashed the RTSP firmware on 2 Cam Pans over the last couple of days. RTSP stream is coming into MotionEye on Home Assistant.

The video quality drops a bit when trying to use it concurrently with motion tracking or panning zones, so I have turned it off. But apart from that its working really well. Have never had any drop-outs, its completely stable. I have a pretty robust home wifi setup (3 unifi AC-pro APs spread across the house) so maybe that helps. Will see if it stays this way after adding a few more cams.

In MotionEye the settings took a lot of tweaking to get the motion trigger (rather than constant always-on capture) and video quality/size trade-off right, Sudden lighting changes and switching between day/night mode with light reflections off the cars in the garage will trigger movement and start recording. A bit annoying but liveable.

So far so good, looking forward to any quality or configurability features that could be added (i.e. controlling camera movement outside the app).

#653

Standard RTSP Port is 554

#654

fryguy, could you please show an example of a full RTSP connect string?

#655

Depends on the camera software you are using. Some have separate fields for each parameter like IP address, User Name, Password, Port, Protocol, etc. If it’s all on one field like VLC use, rtsp://username:password@ipaddress:port/live .
Ex: rtsp://joe:l33t@192.168.192.10:554/live

1 Like