Real Time Streaming Protocol (RTSP)

Blockquote
Are you suggesting that the issue with the RTSP stream timeout is not on the Wyze side?

I am.

At the same time I’m also not trying to say it’s also a possibility that something is flawed with the RTSP implementation, but I personally think it’s not that. Not being someone that has direct access to the Wyze source code or has the time to reverse engineer the firmware pretty much makes me base my assumptions off of experience and other confirmed posts in this thread.

When I start with my situation, which I’ve documented for the challenges that I faced, through all of the software configurations I never had a TCP specific RTSP non+connection issue with 12 cameras running through 3 different brand AP’s. In fact, I was able to use multiple TCP RTSP streams on one camera to multiple computers at the same time. I have had Zoneminder running now for 45+ days recording motion that is around 400GB with no reconnect issues. I’ve had plenty of issues - but found most to be related to network configuration and the limitations of 802.11x that most businesses face with a large data load over wifi. But that doesn’t mean that my use case matches others which is also why I agree it could be the RTSP service on the Wyze cam but I’d need to setup a reproducible scenario.

I also absolutely agree with you that it would be wonderful to have a hard wire to rule out wifi centric issues. Maybe the next version or a firmware update will support this capability.

I’ll see if I can get an answer to that one. :slight_smile:

I looked into this and I’m told that you can kill the TCP connection by turning RTSP off and back on.

Thanks for your patience!

1 Like

Vote for what

Could some of the issues discussed in this thread be related to the version of Live555 being so old?
Is Wyze looking at using a more recent version?

2020-03-24T13:23:06.646414579Z s=Session streamed by "wyze"
2020-03-24T13:23:06.646515630Z i=live
2020-03-24T13:23:06.646560513Z t=0 0
2020-03-24T13:23:06.646623886Z a=tool:LIVE555 Streaming Media v2017.10.28

A post was merged into an existing topic: Fast Forward/Rewind In Playback

It is actually exposure time, not frame rate, that causes motion blur. The two are inter-dependent but not always tied together. For example, the maximum exposure time at 20 fps would be 50 ms, and the maximum frame rate with a 100 ms exposure time would be 10 fps, but the frame rate for 50 ms exposure time can be anything less than or equal to 20 fps, and the exposure time for 20 fps can be anything less than or equal to 50 ms.

Shorter exposure time reduces blur at the expense of light, which basically mean less detail. Longer exposure time can produce better detail but is more susceptible to blur.

1 Like

Does anyone know, is the ability to provide static/snapshot images of the RTSP feed on the development roadmap? Or does the RTSP feed support multiple clients yet (so I could setup a client that just generates snapshots)?

You can have multiple clients on an RTSP stream - I have a couple of mine running with Zoneminder and MotionEye and have had any problems :slight_smile:

You can have multiple clients on an RTSP stream - I have a couple of mine running with Zoneminder and MotionEye and have had any problems :slight_smile:

I agree with this. Its not so much a camera problem, but more the quality of the connection between your camera and WiFi AP, and whether it can manage having 2 RTSP streams coming from the camera at once. I had it running for a little while and it worked, but I found it got a little choppy with high motion scenes. It could have been under-powered hardware since I had both streams going to the same test server in different docker containers, but it felt like it was insufficient bandwidth. The irony is that 2 streams took up less than 5Mbps, so it shouldn’t have been a bandwidth issue either.

You could try and use an RTSP proxy to get the WiFi stream onto your LAN and then split it out from that point onward. I tried Live555, but didn’t like its output stream as it was re-encoded and lost some quality in the process. It may be correctable if you tweak its settings but I couldn’t be bothered.

TBH I haven’t explicitly tested connecting 2 clients…I have had issues using the stream to generate snapshots and starting a live stream simultaneously…and I thought I read (far) further up in this thread that the camera did not support 2 simultaneous clients so I just assumed that was my problem, I guess maybe I need to dig into what’s going on there a little more. Thanks.

I understand WYZE says this about RTSP:

We don’t have the resources to keep developing two branches of firmware for Wyze Cam v2 and Wyze Cam Pan. At this time, we are not committing to ongoing maintenance for RTSP firmware. We will deliver security updates as needed.

I get this, but guys don’t you realize that your sales would greatly increase if you would?
There are allot of people who really want to use this with RTSP. The current issue with your implementation of RTSP is its so laggy & often with to many dropped frames specifically when it it sees a person or something moving.

Why not either open source the code so those of us who have the time can make it better, or invest in creating a RTSP only firmware so that the device has enough CPU time to handle RTSP properly.

5 Likes

Hi, this seems to be the right thread to ask this, but forgive me if it’s someplace in the two years of discussion already. I looked a bit but couldn’t find my answer.

I’m using Wyze v2 with latest RTSP firmware 4.28.4.41 and Synology Surveillance Station (SS). The issue is that the RTSP feed is always at 1080, even when I change to SD or 360p from within the Wyze app. Regardless of what is selected, RTSP feed shows 1080. There appears to be a problem with SS showing 1080 in Live View, so I’m trying to get the stream to a lower resolution to test out.

Is there any way to accomplish this? I’ve tried making adjustments and restarting cam, but that 1080 persists. Anyone? Thanks in advance.

So, setup simple ReefCam to monitor my reef tank and have been having streaming issues with the Wyze app and/or RTSP.ME provider.

I’m running the WYZE android app within BlueStacks on a PC next to reef tank. Then stream RTSP to RTSP.ME so I can embed on website. It worked for weeks then stopped working; so, switched to iplive cam which appears to work now.

Is there an easier more reliable way to stream a wyze webcam within a blog?

https://www.ipcamlive.com/5f56d3e467a86

The RTSP feed, to my knowledge, is always rendered at 1080p. The only variable that changes is the frames per second, as daylight renders at 15 fps and night mode renders at 10 fps.

Most software allows you to transcode this to a lower resolution or bitrate but if you are using a direct stream copy, it will always be at 1080p.

Think of RTSP as a broadcast - it doesn’t change based on what you watch it on and there are no settings that you pass to the RTSP broadcaster to change resolution. You receive the broadcast and convert it from there…

Hope this helps.

No there isn’t, the problem lies within the lackluster RTSP implementation that Wyze developers have provided in the firmware. If you’re using the RTSP stream then you will have issues. Consider a different camera that has RTSP support (this Wyze feature is an unsupported feature) out of the box with the standard camera firmware.

Did you ever find out what made it stop working?

I have 12 Wyze cams all streaming via RTSP and the only issue that I stumble on is that sometimes when the camera’s reboot, they pickup the wrong IP address even though there are reservations for it. It seems to default, if it cannot find an IP address lease, to the address that it waa originally set up with when the pairing process occurred (network setup).

Beyond that, most of my streams have not had an issue.

Did the internal IP address change which then made the port forward from your firewall fail?

@ElectroStrong

What firmware are you using on the Wyze cams, .41 or .40.
Are they Wyze Cam 2 or Pans?
Are you recording any of the streams?
If no, how do you know if the streams drop out or not if you’re not recording?

Every user on here running the RTSP firmware on their WyzeCam2 has problems with the RTSP stream, freezing up/dropping.

On the other note, I thought I was going insane. I am seeing this issue with the IPs, ALL other devices will pick up the IP that is reserved for them, except the Wyze cams which sometimes pick up another IP. I am curious if this is a second issue in the firmware with the RTSP feature. I am running .41 on all cams, I may switch .40 on one of them to test, if I have the time…

Interesting. Someone here recently posted that they saw the MAC address changing. It sounded unlikely, but that could explain why your router’s DCHP server granted it a different IP address.