RE: Wyze Lock Auto Unlock

The issue isn’t an Apple issue per se, it has to do with the antenna constraints on mobile devices. Apple Maps, Google Maps, etc. will all show this drift. Adding another antenna (not possible on most mobile devices) increases accuracy to ~1 meter horizontal, where the best you can expect from a single antenna or single frequency is ~3 meters, and is mostly greater than that. Buildings, trees, etc also cause inaccuracies in location, mapping programs become pretty much useless in places like Downtown San Francisco, for instance because of signal attenuation from the buildings.

There are some smoothing techniques that have been tried to the data provided by GPS, but that results in a tradeoff in accuracy while driving (as speed goes up, smoothing results in slower position updates).

I used to work on GPS-based systems up until 3 years ago…

1 Like

Thanks for the clarification. I know people have said that there are better options to use for the auto unlock than GPS. You would probably know better than anybody. So thank you for clarifying the information and we will just have to live with what we got

I would be curious to know if someone using your tablet in a different location on the same account will cause your location to jump around.

Yeah, well, that actually don’t make sense, since the lock is advertised as you being able to share locking/unlocking with other people, and odds are, most of the time there will still be one or more devices around the area, especially in a family home.

The WyzeLock is just really buggy still…

1 Like

I had a problem similar to this with my Alexa app, it was not kicking off my “arrive home” routine. It drove me nuts too, but I found on a forum that at least on an android, If you have your phone inactivating Alexa to save the battery, it can cause problems like this. When I turned this feature off for Alexa, it started working correctly. Something to try if you have the Android killing the Wyze app to save power. (Settings / Device Care / Battery on my phone).

1 Like

Moderator Note:

The recent discussion in this thread about wifi being hacked is not directly related to Wyze (specifically Wyze Lock auto unlock) and has been causing significant discord. Therefore, all posts on that subject have been removed per the Community Guidelines:

  • Keep posts relevant to Wyze.
  • Don’t divert a topic by changing it midstream.

Please keep all future posts in this thread related to title subject.

3 Likes

My auto-unlock was working fine for a couple of weeks and now does not. I have changed nothing? Frustrating.

1 Like

I’m thinking – at least for me – this is more an issue with the Wyze app and/or Android than with the lock itself. It seems like every hour or so, the Wyze app drops off from the “background” list. If the geofence isn’t running, the conditions can’t be met for unlocking, right? (I think I’m understanding this correctly.) There are two steps: (?)

  • enter geofence area
  • get phone to connect via Bluetooth

I’ve had some problems with the second, even when standing inside the house and trying to adjust lock settings, so I’m not sure, but here’s an edited screenshot of my phone’s status bar before and after launching the Wyze app. I just checked the phone again about an hour later, and the “geofence” notification is gone again… :frowning:

I have a support ticket in, but wondering if others are seeing the same problem or have noticed. I think the app notification is a new(er) Android 10 thing. I have also just tried adjusting the battery setting for the Wyze app to be “unmanaged” (or whatever they call it).

1 Like

I installed the lock, worked great with the auto unlock for the first 2 days. Then the auto unlock stopped working and hasn’t worked since. I removed both devices from my menu and re added them, still nothing. This is the whole reason why I bought 2 of these locks. I only installed 1. I hope this is a bug that is being worked on and fixed ASAP.

BTW: I am on iOS

1 Like

Update: Ensuring that the background app that says “Geofence is running” is always displayed appears to have solved most (all?) of my auto-unlock issues. This appears to have been an issue with the battery optimization settings for the Wyze app in Android.

1 Like

Glad you got it fixed or figured out. I am not a expert or even a novice on android so I was of no help I apologize.

Is this background app on the apple phone too and , if so, where do I find it? My Auto Unlock stopped working and I would like it back. I am not too tech savvy!

1 Like

No the background app is not in iPhone you can have an app running in the background which is means where you have it open but you’re not using it. Which you probably do a lot. And then to force close them you swipe up and that force close as them if you don’t swipe up there running in the background

You may want to reach out to support. They sent me a long list of steps to try. I had already tried several, but step 4 (or something) reminded me to check the battery optimization (which Android can do app-by-app). Not sure how it works on iOS, but I’m sure Wyze support does and can offer tips.

This battery app setting has – so far – fixed auto-unlock for me 100%.

1 Like

iOS does not have battery optimization just FYI

1 Like

Yup, very true. Although there is Background App Refresh and if that’s turned off for Wyze, I suppose it could cause some problems.

1 Like

Went out to Cherry Hill today and when I came home, the Auto Lock worked?

1 Like

I updated my app and it said there was a bug fix for auto lock accuracy, still doesn’t work.

1 Like

I updated my Wyze app, which was supposed to fix “auto-unlock / auto-lock” issues, but it only made matters worse. Prior to the update, my lock would only “auto-unlock” about 25% of the time when I returned home from work. Also, it was unlocking randomly in the middle of the night when I was home. After the update, my Wyze lock does not “auto-unlock” at all! It does not seem that Wyze can get this feature to work properly, I am running a Google Pixel 3a with Android 10. I would not have purchased this lock if I knew auto-unlock did not work.

1 Like

Please submit a Support Request on this so that the team will hear of your experience. The forum is not closely monitored by Wyze Support.