Question and issue re: a nightly schedule

I’m still within my first 2 weeks of using these things, so here’s today’s topic.

First, my question is this: how is the ending time supposed to work for something like “Turn on motion detect”? Does the motion detect turn back off when that ending time is reached?

I have a nightly schedule made for turning on motion detect in one of cameras at 11 p.m. At first I put 7 a.m. next morning as the end time. I think it successfully turned on and off that first night. Since then, it has had an issue of turning motion detect back off.

Okay, I just looked through the history and that first night it did say that the 11:00 to 7:00 event of turning on motion capture was successful. After 2 mornings of the motion detection still being on, I took out the ending time and made another schedule for turning off motion detection at 7:00 a.m. Turning on motion detection at 11 always works, but turning it off at 7:00 still shows that it failed.

What I just set and will try tonight was to put ending time a little before 7:00 and then keeping the 7:00 even to turn off motion capture. Maybe one of those times will be successful at turning off the motion capture.

Not sure which devices you are talking about. But since you mention motion detection, it works like this:

You set a schedule that says turn on motion detection at a certain time (Start Time). If you provide an End Time which is optional, the action would cause your motion detection to turn off.

I actually setup my Scheduled Rules as follows:

Basically, I have a schedule setup to set a Mode for the home. Each mode will turn on and off items based on time of day/night. I provided a sample of what I did for my Morning mode.

So as each mode is triggered the appropriate action is performed and turns on or off items.

However, if you setup one Scheduled rule with an end time, it is supposed to turn off the devices you were acting on. So if you turned a light on, it would go off. If you turned motion sensors on, they will turn off, etc.

Which Camera’s are you trying to control and what is the version number of the Camera’s Firmware?

Setting it a minute or two before or after the hour has worked in the past as there was an issue with the older Rules Engine. We are on the New Rule’s Engine which has corrected that for me. But if you do the adjustments, I would move it ahead by a few minutes.

Thank you for the detailed response. I was assuming that putting an end time on the scheduled event would reverse whatever you did originally, but it’s good to have confirmation.

It is a v3 camera, the one I have in the living room, that I’ve put this schedule on. Firmware version is 4.36.3.19, which should be the latest one.

I’m going to see what happens tonight now that I have an end time put in for the “turn motion detection on” event and also have a separate “turn motion detection off” event scheduled for about 15 minutes after that. I’ll see if at least 1 of them is successful or if both of them fail.

I guess my question now boils down to this: what would cause an event to fail?

1 Like

Yea, that is the latest FW for the v3. I signed up to beta Test FW as well as he apps. so my version is different from what you have. If your test is not successful, let me know and I will test on my side with the Beta FW for the v3’s.

Dude, do you have any spare time? I want you to work for me… at the same wages.

All kidding aside, you do great work here, Mr. 'moni. Cheers. :clap:

1 Like

Spare time, would like to know what that is. Appreciate the comment. I try to provide the same level of support you all do. It is difficult as we all have different talents. :slight_smile:

I am glad that there are others, like you, in these forums providing the support as well. I find this all fascinating, call it a sickness.

Thanks again

1 Like

Hey, thanks. I’ll report back on this thread tomorrow.

1 Like

Please realize that I am not affiliated nor an employee with Wyze. I am a community member as you who opted to be a beta tester of the apps and firmware as well. Just something I enjoy doing.

Looking forward to your results.

My first schedule, to turn on motion detection and turn it off a little before 7, succeeded. Motion detection was in fact turned off this morning. The second schedule that simply turned it off at 7 failed, I think because motion detection was already turned off.

I’ve noticed when I’ve accidentally hit my shortcut icon to turn on or off motion detection that it leaves an error entry in the history log if what I hit was already in that state (motion detection off when it was already off).

Wonder why it shows up as an error. Seems like it would say “Oh… okay. I’ll turn it off, sure! wink

:slight_smile: Glad your one rule worked. I always do seperate rules for on and off. Only because in the past there was an issue and it was already a standard routine now.

Would you like me to create a shortcut for activating the Motion Detection and see if it throughs an error in the History.

What I would also do is submit a log of this and post it in the forum with the Log. Wyze occasionally review these forums and can use the logs.

@WyzeQi , any idea on the issue @iamtherealmiggy is having with his rules regarding the v3 camera’s?

Yes, I’d be curious if you also would get an error in the history if you turned motion detection off with a shortcut when it was already off.

I haven’t looked into how to create a log, although I have seen that option while looking through the various app pages. Is that something you have to set up before so that it would log this error, or something you can do after the fact?

For the log:

Go to the Camera start the live stream, the click the gear at the top right, then scroll to the bottom and select Wyze Support finally submit log.

I just did a test and everthing succeeded.

  • I turned motion on, checked and it showed everything was fine
  • I turned motion off, checked and it showed everything was fine
  • I turned morion on, waited a few seconds then turned on again - no issues in the rule history
  • I turned morion off, waited a few seconds then turned off again - no issues in the rule history

I did another test and this time turning off motion detection while it was already off did not cause an error. I dont know what caused the previous errors.

I removed the reduntant event that turned off motion detect and just left the one that turns it on and off again. I’ll see how thwt works tonight.

1 Like