Problem with geo-fencing away mode

Has anyone / everyone had a problem with geo-fencing (away mode)? Might doesnt seem to work. I reset it completely. Reset it up and when I went away it said away, then home when I got home. I thought it was working. Shortly thereafter it was continually saying I was gone again and setting the temp down low. Have you guys had the same experience?

I have experienced a similar issue (though in reverse) where I have left my home for a number of days and while initially set to away, after a day or so the thermostat reverts to home mode. While troubleshooting, I am wondering whether the schedule is overriding geofencing? The thermostat is installed in a vacation home, so when I leave, I want the thermostat to remain off. But after the last firmware upgrade 1.1.7, I discovered that the thermostat was happily heating my empty home. Note that I had a schedule set, but assumed that being away would keep the schedule from running.

Not sure if this is related or either of these issues or not as I don’t use geofencing but I have noticed that on occasion I can change something through the app (state, mode, temp, fan) and it will after about 5 seconds revert to the prior setting. Sometimes after I try it 2-3 times it will stay but this weekend I resorted to going to the wall control to make the change with no problem. I have 2 thermostats for dual zone and they both exhibit this behavior. I tried resetting one of them and going through the set up again and it still on occasion does this. I also deleted the app (Android) and reinstalled with no luck either.

I’ve definitely experienced the same thing on occasion.

I also have this problem. It will not stay on the schedule I set and constantly goes to the wrong temperature when switching from away to home.

It also will not stay in away mode as it is supposed to due to the schedule. It’s actually raising my electric bill because it is supposed to be set to 85 when I’m not there and it switches back to 70 on home mode several times during the day

I have done some testing and have come to the following conclusion: A schedule will override everything else - be it auto switch or manually setting home/away/sleep. Use a schedule if you are really home all the time, or use autoswitch if you go out at different times of the day. Using both at the same time will produce unintended results.

I had hoped that the thermostat would actually have worked in the opposite manner, where a schedule would be overridden if autoswitch reported you were away or you set it manually. Put another way, the schedule would run when you are home, and then switch to the default away temperature when you were away. Makes sense, right? IMHO, that’s how the thermostat should operate, instead of forcing users to choose between a schedule or autoswitch. If that were the intent, then shouldn’t setting a schedule disable autoswitch, and vice-versa?

Here’s an example: I usually arrive home from work at 5pm, but one day I stay out late and get home at 9pm. If I use a schedule and autoswitch, the thermostat will activate at 5pm, even though I don’t arrive home for 4 hours. In a similar manner, if I arrive home early at 2pm, the thermostat won’t activate until 5pm because the schedule overrides the autoswitch. And finally, if I arrive home at 5, but then go out at 7pm, the thermostat will run on the schedule instead of recognizing that I am away. Why use autoswitch at all it it has no impact on use?