Possible solution for lost person detection announcements in alexa

I can’t see how that would happen without flashing firmware.

PD IS enabled in Alexa on the three cameras that DON"T have PD enabled in the Wyze app. These are the only three that stay consistant. I don’t know if it actually works but the routine ability is there.

It’s been happening for months. In my case, I don’t know if it ever worked right.

I am dealing with a similar issue. All cams in the Wyze app have been enabled for PD but only one of them is showing that option in the Alexa app. I also changed the name of one of the cams and lost that option in Alexa.
Any idea if this is going to be fixed?

I finally got around to testing this today on my 3 cams that weren’t working right in Alexa (3 that weren’t allowing PD triggers). angus.black is quite right: I also just went into a production version of the Wyze app using my daughter’s old phone, selected the camera in question, then settings, name, save (without even changing a single thing at all), and went back to alexa, refreshed the screen and it was totally fixed just like that. PD trigger and PD announcements were suddenly available and working as intended. It was really, really simple to fix. I really appreciate you sharing this work around @kjay Hopefully Wyze will fix this issue in the Beta app.

3 Likes

I tried this about a month ago and it didn’t work. I tried it tonight after seeing this post and it works! Thanks!

1 Like

Did it keep working?

I have 3 of 8 cameras that work in Alexa. The others will work if I save the name in the Wyze app but only for short time.
I don’t know yet what makes them drop from Alexa.
There’s no common attributes withe the 3 cameras that some of the 8 don’t have.
It’s just ridiculous that Wyze can’t tell us what is going on here.

You’re right, the 3 of mine that were “fixed” in Alexa by doing this trick on 01/04/21, dropped the Person Detection trigger ability again sometime between then and when I checked again today 01/17/21.

Did anyone in here get their cams to stay “fixed” in Alexa for at least 2 weeks?

That is weird. You’d think this should help make it more obvious to Wyze/Amazon how to fix the problem when saving the name suddenly fixes the issue temporarily…why does it suddenly recur through?

Nope, it stopped working after about a day. The weird thing is, I kept getting announcements even when the option was no longer there to turn them on or off. The option reappears everytime I save the camera name. I don’t know what makes them drop from Alexa either. I only have 1 of 7 that works all day everyday.

The rename thing only works in the production version of the Wyze app, not in the beta.
I wrongly assumed that using the beta app was causing to not see the cameras.
I dropped out of the beta program and installed the production app on my main device. It made no difference.

1 Like

Interesting. Though it is possible that the beta app still caused the problem since you used to have the beta app and those cameras could’ve been corrupted by it somehow before you dropped out.

If you drop out of beta, roll the camera firmware back to an earlier version (so it’s not still beta either), then delete the camera from the app, then reinstall the camera in the production app, and never add beta again, I bet it would stay working (I’m not very willing to try this, at least not long term, because I love beta-testing). I could be wrong, but I bet that would resolve it. If you try it, it would be interesting to hear if that works.

It has never worked for me. However I am using the Beta version of the app.

Regards,

Bryan

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

@SolarGoat are you using the beta app or firmware?

It’s probsbly worth a try but 2 of my 3 working cameras have beta firmware too. One has RTSP. All 3 working cams are V2.
I have 3 more V2 and 2 Pan cams all with beta firmware that don’t work.

1 Like

Production version.

Thanks. Kinda proves the beta version causing it is incorrect.

1 Like