[POLL] Wyze App will exclude pre-Android 7 Devices

 
Regarding the Wyze App exclusion of pre-Android 7 devices:

  • I object
  • I accept
  • I object to the short 5-day notice in any event

0 voters

Kinda ridiculous that I can choose both “I object” and “I accept”, lol

1 Like

Might finally force my wife to get her a new phone. She doesn’t trust the cloud with her pictures and hasn’t been able to update it fir a few months now.

1 Like

OTOH, it’s compact! :grin:

Point of pride, eight year old tablet and the battery still has great capacity, only thing I can think to explain it is the slow wireless charging I’ve used from the beginning. :crossed_fingers: :slight_smile:

Also, gorilla glass, with thousands of little nicks from my fingernails apparently, so customized by use. :framed_picture:

Nice post by Carver:


So, clock’s ticking down: no rationale to be provided for the necessity of a short 5-day notice?

1 Like

Thanks Peep

To be fair, it was almost a 7-month notice as they posted the original warning on 6/16/21 with the expected change to take place 7/7/21 , but was then “postponed to give folks more time to find compatible devices” and then told everyone back at that time “We’ll move forward with this change later this month or starting next month instead.” which meant everyone was warned they should get new devices by August 2021…and then they gave a whole bunch of extra time (that is not to say that I don’t also think it would’ve been nice to have a little bit bigger warning on a definite date that included a couple of weekends worth for people to plan going to the carrier or awaiting a new delivery), but they have been telling us this for 7 months now…and it’s hard not to see that as sufficient warning…

I think they acted reasonably by postponing the deadline at least twice, and if 7 months of warning didn’t change anything, I am not sure that more time would make much difference. At some point they have to activate their new security stuff. It is very sad that some people will be negatively impacted. As a temporary work around, people can install Bluestacks on their computers and run the Wyze app through that, so they will at least have access to everything on their computer while they look into getting a new phone or tablet or whatever that at least has Android 7 or iOS 12.

I’m pretty sure they previously announced that Android 6 devices would be excluded from future app updates - not that the last valid app for Android 6 devices would be blocked at some point.

Can you point me to an instance of the latter?

Otherwise, it’s a 5-day notice of a new blocking policy.

1 Like

That is a fair enough point, my friend. I did not consider that, especially with the clarifications under the update log there. I should have realized the difference. Thank you for the clear posting and correction clarification. What I said had some incorrect assumptions and I thus accept that I was wrong and you were right. :slight_smile: Don’t get too used to it!

I am curious what the big rush was and why more warning about the change was not given. Given that they said here that “this change is being made to support upcoming security changes and features”…it makes me think there must have been a recent security issue. I read of something weird happening on Reddit very recently (like in the last week or so), and Wyze security got involved and started investigating how such a thing could have happened. It would make a lot of sense if they found out it had something to do with someone using an app version pre 2.22 and that it was because it was missing the latest security updates that exposed some kind of bug or vulnerability they just can’t risk allowing to continue anymore.

A situation like that would make total sense why they would not allow a lot of advanced warning, but would instead tell people there isn’t time to spare and they’re no longer going to allow the insecure apps to functions any longer. Furthermore, they don’t want to say WHAT the security is until it’s resolved, otherwise a bunch [more] people could go exploit it during this 5 day grace period.

THAT would make sense, and be fairly reasonable…most of the time, given enough time and information I have been relatively satisfied with Wyze’s decisions as being at least reasonable, if not always the way I would’ve preferred, and sometimes I dislike and disagree with some of their decisions, but when I have enough info, I usually find they are reasonable. I can’t say I have enough info right now, but given the info I do have (that 2.22 and above had some critical security changes, and that 2.21 and below are MISSING these critical security needs, and that Android 6 and below are incompatible with some of these changes…that is enough information for me to give them the benefit of the doubt that they had something happened or discovered something that required time-sensitive action, and disclosing all the details before the fix is fully in place could cause more harm than good. That’s all fairly easy to deduce. Still, my curiosity does make me wonder exactly what the rush was. :slight_smile:

Regardless, I do have an old phone with Android 6 and I sideloaded a 2.21 version app onto it so I can see what happens with the changes and what options are available for resolution in order to experience what happens and try to see if I can help out people in some way. We’ll see. It’s almost time.

1 Like

Nah, you threw that one to me because you know I’m old and pathetic and needed a win. Your whole life is unrolling before you while mine spirals down the porcelain bowl (kinda fun, actually… :grin: )

This is a complicated game getting more knotted by the day so I give them their security due. Thanks for sharing those Reddit indications - it’s a boatload better than nuthin! :slight_smile:

1 Like

image

Still working, atm…
 
image
 
Amazing grace…?

image

image

And?

 
peep?