Plug firmware update failed

i tried to upgrade firmware on on of the plug and it failed at the end. Now that plug is not getting detected and even deleting the device and try to add again seems to not working. i dont see wyzeplug_wifi_something in my available networks anymore. any other ways to reset and add the plug

I’m not sure about this plug but I have another plug that if I hold the power button down when I plug it in the plug resets to factory default

After plug is plugged in ( powered on ) If the status light is not flashing blue, press and hold the on/off button.

i did try that. the blue light is flashing quickly now but i dont see that wyze_smartplug_ad080 anymore in my network connections. I have not upgraded my firmware on other plug and that is working fine. Is there anyway i can roll back the firmware on the plug

Flashing blue status light means it is in pairing mode, Select Add Product and go through the rest of the setup


i tried that but when i have connect wyze_smartplug_ad080 network i dont see it as available anymore

Pressing and holding the on/off button should be resetting the plug to factory settings as if it were new out of the box. If that’s not working, try the steps here:

If you continue to have problems, you will need to make a Support Request.


I am going to try and replicate your issue but let me see if I understand what is happening.

  1. Plug installed fine
  2. Went to upgrade firmware and firmware update failed (did you get the update failed message)
  3. After failed update plug would not work
  4. Deleted plug from app
    5 Tried to setup but when you get to point of telling you to connect to plug wifi you dont see it

Is that correct, and did you get the firmware update failed message.


Since you are having so much trouble, try cycling power to your router. Wait several minutes until you know it is up and working again, then plug the Plug back in and reset it.


Sorry to hear you’re having trouble! Can you use a computer or second phone to see if the network is visible from that device? We need to figure out if the issue is that your phone can’t see the network or if the Plug isn’t sending one out for some reason.


Yes Jason. This order is correct. I got the update failed message and then the plug was not getting recognized. So I deleted the device and tried to add again, but I don’t get the wyze_smartplug_adp080 like I got before.

I did delete the wifi network from my saved list and retried.

See post above

Hi Mike…
I tried my wife’s phone and couple of other laptops. I don’t see any network named wyze_smartplug_adxxx

Another observation…
When I press and hold the on/off button, at time I see that light being on for long time and then going to fast blinking… At times it turns off and fast blinks. Do you know whats the difference between both

Did you power cycle your router as I described in #9 above?

1 Like

I did try that. The wifi network wyze_smartplug_adxxx came up and went away. The network timed out. Now I don’t see the network again