Phantom Beta Sensor Bridge

I’m having multiple issues with a camera.

  1. I used this camera for testing the first several versions of the sensor bridges. I’ve since removed those old bridges from this camera and it no longer has any bridge installed. However, the camera still shows the bridge as connected. See below screenshots. It keeps prompting me to upgrade the firmware of the bridge. I tried to factory reset and tried to installed clean firmware from the SD card, but nothing works.

  1. Related to the above issue, the camera doesn’t seem to be recognizing any SD cards. I tried three cards, including one that I knew was working from another camera. When installed, the camera would appear to have a card installed, but it would be non-responsive. It shows as 10MB/0MB. I tried to check the cards afterwards on a windows computer and they were unrecognized. The camera seems to have bricked/destroyed three SD cards!

I’ve sent in a trouble ticket to support about these issues, but it has been over a week. So I thought I might post this here.